Help: CLS Installation - cl-update error

Hi All,

I am struggling with a new install of CLS - Calculate Linux Scratch.

CLS is installed and I can boot and log into the base system.

However, when I try to update the system as root with the cl-update command, I receive the following error:

  • Repositories synchronization
  • Searching new binhost …
  • Checking distro updates …
  • Git git:// is unavailable
  • Failed to find the binary updates server
  • Update failed

The problem seems to be the git URL.

  1. Where do I find the controlling file that is using this URL to complete the cl-update command?
  2. Once the file is located, what URL should replace the git URL?

I thank all for any assistance with this error.


PS - for those that may ask, I am able to ping popular websites like google and yahoo. This indicates that networking is functioning properly and not the cause of the failure to reach the update URL listed above.

It is possible that the following commands will be of use:

cl-core-variables --set update.cl_update_binhost_list=
cl-core-variables --set update.cl_update_binhost=

You need to specify an update source of your choice then.

Hi freedoreme,

Thank you for the suggestions.

I tried them all and am still left with the original error message.


Hi tileman.
I am sorry to hear that you still have a problem with updates. I have never tried anything apart from cldx.
Have a closer look at this discussion. It may be more relevant to your situation.
P.S. Another suggestion looks like more promising. The problem in question seems peculiar to cls only.