Calculate Forum

Failed to find the working server with updates

I get this error occasionally, I tried different servers with the same result.

cl-update -v

Repositories synchronization

  • Searching new binhost …
  • Failed to find the working server with updates
  • Fallback syncing the Distros repository …
  • Git git://github.com/calculatelinux/distros.git is unavailable
  • Failed to find the binary updates server
  • Update failed

Could this be because my system is already up to date and there are no new updates available?

BHReach, tell me please - what’s your version of Calculate server or desktop?
Executing the command:
sudo eix-sync && eix-update
didn’t help you?
Or try to synchronize each repository that is connected to your system:
sudo emaint sync -r gentoo
sudo emaint sync -r calculate
sudo emaint sync -r distros

Sincerely,
Slyusardi

I installed using a recent cls nightly iso.
Here is all the info I was able to get about the version and release:

cat /etc/issue
Welcome to \n.\O (Calculate Linux Scratch 21)

cat /etc/os-release
#------------------------------------------------------------------------------

Modified Calculate Utilities 3.6.9.25

Processed template files:

/var/db/repos/calculate/profiles/templates/3.6/2_ac_install_merge/sys-apps/baselayout/os-release

For modify this file, create /run/calculate/mount/install/etc/os-release.clt template.

#------------------------------------------------------------------------------
NAME=Calculate
ID=calculate
PRETTY_NAME=“Calculate/Linux”
ANSI_COLOR=“1;32”
HOME_URL=“http://www.calculate-linux.org
SUPPORT_URL=“http://www.calculate-linux.org/main/en/community
BUG_REPORT_URL=“http://www.calculate-linux.org/projects/calculatelinux/issues

cat /proc/version
Linux version 5.10.53-calculate (root@localhost) (gcc (Gentoo 10.3.0-r2 p3) 10.3.0, GNU ld (Gentoo 2.36.1 p5) 2.36.1) #1 SMP PREEMPT Wed Aug 25 08:02:57 UTC 2021

cat /etc/gentoo-release
Calculate Linux Scratch 21

uname -por
5.10.53-calculate AMD Ryzen 5 5600X 6-Core Processor GNU/Linux

This is only a temporary problem. If I wait a while the update usually works.

Next time it happens, I will try your suggestions.

Thank you.

Good!) I also want to install and use Calculate Linux Scratch 21 - I hope we will share our experience)

© 2007-2020 Calculate Ltd.
Mastodon Mastodon