Canon printer doesn't print

I’ve just installed Calculate and it is shaping up to be very good. I have a Canon ip4850 printer, I used localhost:631 to install it, and was pleasantly surprised to find my printer in the list of drivers (ip4800 series). It installed OK, but does not print. Everything looks good and it says the job is complete but no output. Has anyone else had a similar problem?

paste your CUPS Error log:

CUPS (localhost:631) > Administration > View Error log <

There is no error log, the localhost:631 page says that all is good, the job printed. I tried the printer using Windows 7, thinking that the printer may be faulty, but it worked fine. The indicator light on the printer blinks as though it was printing but nothing happens. I have reinstalled the driver twice, but no go. There is an ebuild for the printer, but I have no idea how to use it.

Hi All :slight_smile:

Having the same problem I write here instead of opening a new thread (hoping am not wrong doing that).
I have last release of Calculate KDE 32 bit and can’t use my printer Canon PIXIA MG3540 (MG 3500 Series); needing the file “cmdtocanonij”.
Googling around I found an ebuild which can fix the problem, I suppose, but can’t use it because something is wrong with the link even after adding it to:
I have been writing to the developer too but he does’nt write back to me. This is the link:
Have been trying many ways as “gutenprint”, try to install “rpm” and other tricks, got nothing.
Any idea?

Thank you for your kind attention

I’m speak spanish and my english is bad.

1.- Print (to know the error in log)
2.- See your log of cups in /var/log/cups/error_log
3.- Check in google with the error.
3.1 Else post your error_log in the forum

Hi Carlos,

Muchas gracias :slight_smile: is impossible to add the printer, this is the log:
( /var/log/cups/error_log )
E [27/Jan/2015:10:03:45 +0200] [cups-driverd] Bad driver information file “/usr/share/cups/model/foomatic-db-ppds/Kyocera/ReadMe.htm”!
W [27/Jan/2015:10:05:08 +0200] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [27/Jan/2015:10:05:08 +0200] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
E [27/Jan/2015:10:05:12 +0200] [Client 17] Returning IPP client-error-document-format-not-supported for Print-Job (ipp://localhost/printers/Canon-MG3500-series) from localhost
E [27/Jan/2015:10:07:40 +0200] [Client 18] Returning IPP client-error-document-format-not-supported for Send-Document (ipp://localhost:631/printers/Canon-MG3500-series) from localhost
E [27/Jan/2015:10:09:05 +0200] [Client 13] pam_authenticate() returned 7 (Authentication failure)
E [27/Jan/2015:10:09:57 +0200] [cups-driverd] Bad driver information file “/usr/share/cups/model/foomatic-db-ppds/Kyocera/ReadMe.htm”!

Do you know if there is a rpm or deb package for your printer?
Later I see the error of your log because I’m working in the office.

…some time ago I downloaded some packages (still I have them):

  • cnijfilter-mg3500series-4.00-1-rpm.tar.gz # if am not wrong this one contains “cmdtocanonij”

  • cnijfilter-source-3.40-1.tar.gz

  • cnijfilter-source-4.00-1.tar.gz

  • gutenprint-5.2.10.tar.bz2

  • scangearmp-mg3500series-2.20-1-rpm.tar.gz # scanner

  • scangearmp-source-2.20-1.tar.gz # scanner
    I don’t remember if I have been trying all of them but I have been unable to install; also trying to copy the file “cmdtocanonij” from Ubuntu no good (the system was not seeing it).
    I did the attempts with my previous Calculate, which I removed because after removing the “cnijfilter 3.80” (original of the distro) impossible to reinstall it.
    I have been installing Calculate again because I like it, still not working “deep” on it, also because I am afraid to destroy something again (and for lack of time).
    That’s why I have been writing to the Forum, hoping to get clues for that ebuild because I have been trying to install .rpm for sure but got nothing as the Gentoo Wiki warns.
    ( I am Italian and my English is bad too ). Cheers!

In Zugaina is the ebuild of the driver of your print ( Download the ebuild of cnijfilter-drivers-3.40 and create your own overlay (local overlay). Follow the steps in

After cl-update, and emerge cnijfilter-drivers-3.40.

I have a printer Xerox phaser 6000 and I did the steps above.

Hi Carlos, Thank you :slight_smile:
The point is, all the cnijfilters in that page don’t talk about Canon MG3500 Series.
The one including MG3500 Series is this one:
but as I wrote in my first post, something is wrong with the link and is impossible to install it; I wrote to the developer wishing to inform him but he did’nt write back to me till now.

I’m sorry but that model is your print Canon MG3500 or ip4800 series???
If is Ip4800 serie, you use the ebuild of zugaina
if is MG3500, then use the ebuild of bar-overlay

before installing, see if the ebuild has enabled use=ip4800.
How? emerge -pv =net-print/cnijfilter-drivers-3.40 and if it appears with “-ip4800” then it is disabled for your printer and then in /etc/portage/package.use/custom, added " =net-print/cnijfilter-drivers-3.40 ip4800 " (without the quotes, no spaces).

I just realized that you use a theme of more than three years ago.
Now I research about your printer MG3500

Yes Carlos, mine is Canon PIXIA MG3540 (3500 Series)


1. Download this file: and move to /usr/portage/eclass/
2. sudo chown root.root /usr/portage/eclass/ecnij.eclass
3. sudo chmod 644 /usr/portage/eclass/ecnij.eclass
4. create a overlay local (google it)
5. sudo mkdir -p /usr/local/portage/net-print/cnijfilter/ (if /usr/local/portage is the directory local of your overlay local)
6. move file cnijfilter-4.00.ebuild to /usr/local/portage/net-printer/cnijfilter/ (if /usr/local/portage is the directory local of your overlay local)
7. cd /usr/local/portage/net-printer/cnijfilter/ (if /usr/local/portage is the directory local of your overlay local)
8. sudo repoman manifest
9. sudo chown -R portage.portage /usr/local/portage (if /usr/local/portage is the directory local of your overlay local)
10. sudo cl-update
11. edit file /etc/portage/package.use/custom and add this: =net-print/cnijfilter-4.00 backends mg3500
12. edit file /etc/portage/package.keywords/custom and add this: =net-print/cnijfilter-4.00 ~amd64
13. sudo emerge -v =net-print/cnijfilter-4.00


Hi Carlos,
First of all I wish to say thank you to you once again for the big effort you doing to help me.
I have been following the instructions, even afraid I did something not useful creating the local overlay following this guide:
anyway, I have a doubt for this line:
net-print/cnijfilter-4.00 ~amd64
which I have been adding to:
it seems to be for 64 bit OS, mine is 32 bit (i686).
At the end of story, after downloading the file
and followed all the steps, I downloaded the file
and after doing the command
sudo emerge -v =net-print/cnijfilter-4.00
this is the terminal’s output:
Calculating dependencies \ * Missing digest for ‘/usr/local/portage/net-print/cnijfilter/cnijfilter-4.00.ebuild’
… done!

!!! All ebuilds that could satisfy “=net-print/cnijfilter-4.00” have been masked.
!!! One of the following masked packages is required to complete your request:

  • net-print/cnijfilter-4.00::http-data-gpo-zugaina-org-bar-overlay-eclass (masked by: corruption)

In other words, again comes out the problem I have been talking about starting the thread (that file is corrupted).


  1. For 32-bit systems you should use x86 and non i686 (although I can be wrong). Therefore in the write files /etc/portage/package.keywords/custom (you look out you must have the sign =) =net-print/cnijfilter-4.00 ~x86 (this is to unmasked)
  2. edit file /etc/portage/package.use/custom and add this: =net-print/cnijfilter-4.00 backends mg3500 (you look out you must have the sign =).

3. I have a little problem with ecnij.eclass of your printer because it was erased on my system (surely must belong to a package and therefore build an ebuild and I am researching). What you can do is copy the file each time you turn on the computer until I can find the solution (or you or anyone else)

… I did the steps and suppose followed the whole process.
Giving again the command
sudo emerge -v =net-print/cnijfilter-4.00
I get the same result:
Calculating dependencies | * Missing digest for ‘/usr/local/portage/net-print/cnijfilter/cnijfilter-4.00.ebuild’
… done!

!!! All ebuilds that could satisfy “=net-print/cnijfilter-4.00” have been masked.
!!! One of the following masked packages is required to complete your request:

  • net-print/cnijfilter-4.00::http-data-gpo-zugaina-org-bar-overlay-eclass (masked by: corruption)

1 - Just noticed the file ecnij.eclass disappeared in /usr/portage/eclass and even if I copy it again over there disappear again.
I have it in /usr/local/portage/net-print/cnijfilter

2 - Did something wrong installing another package, system unusable.
Needing to reinstall it, will do as soon as possible

The idea of having your own overlay is to avoid installing untrusted programs, so, you download only the packages Gentoo and Calculate. If you add a new external overlay possibly provoke instability of your system.
I tried to install the printer and I could not. I would recommend you download the rpm or deb and unzip and install it manually each file into your system.

Yes Carlos :slight_smile:
I will write down the final result here when I get time to work on it, I have to reinstall Calculate.

Canon printheads are separate from the tanks and can usally be removed for cleaning.

Lift the top cover of the printer. Flip the inner cover down until it meets the paper output tray.

Lift up on each ink cartridge tank to remove them from the cartridge holder. Set the cartridges on one side so that the ink nozzles are not damaged.

Lift the lever beside the cartridge holder, which is the print head in this model. The print head will lift slightly when you raise the lever.

Pull the print head straight up out of the printer.

Rinse the print head thoroughly under warm running water from the tap taking are not to get water in the circuit board on the back of the print head. Run the water particularly into each hole where the print cartridges sit and underneath where the ink comes out. Do this until the water runs clear. Shake the print head vigourously to remove excess water and then place on a sheet of absorbent paper to dry. Reassemble, run a couple of cleaning cycles with the print cartridges reinstalled and try the print nozzle check again. I have done this with several Canon printer in the past and found it works.

Some people recommend standing the print head in warm water overnight, other have used isopropyl alcohol - personally using running warm water has always worked for me although it can take several goes.

see: , &

Old thread this one, even I forgot it; good to know that Canon printheads can be removed for cleaning.
After that, I can say that no problem on CLD 2018, I have been able to install Canon printer MG3540 (3500 Series) simply using CUPS web interface.