Calculate Forum

Встречайте Calculate Linux Windows 10

Сборка-ПРИКОЛ над некоторыми бухами.
Есть мелкие ошибки. Решаем.

https://ftp.linuxbuh.ru/distros/linuxbuh/lb-windows10-20210420-x86_64.iso
ftp://ftp.linuxbuh.ru/distros/linuxbuh/lb-windows10-20210420-x86_64.iso

Что кроме тему вин10 меняли в iso?
Помимо того что видно на скриншоте

Много что менял.
Но это не только косметика.
Если кому интересно могу расписать.
На самом деле это CLDX+доп программы и внешний вид
Самый простой способ получить вид винды:

  1. Взять CLDX
  2. взять или ebuild linuxbuh/kali-undercover-2021.1.2-r1.ebuild at master · linuxbuh/linuxbuh · GitHub или http://archive.kali.org/kali/pool/main/k/kali-undercover/kali-undercover_2021.1.2.tar.xz или просто положить в хомяк все что в папке linuxbuh/profiles/templates/3.6/6_ac_desktop_profile/2-user/xfce-base/Xfce-4.10 at master · linuxbuh/linuxbuh · GitHub

Внешний вид - это проект Kali Undercover Kali Undercover | Kali Linux Documentation
Kali Linux получил секретный режим, который маскирует его под Windows 10 / Хабр.

В данной сборке работает из коробки

  1. КриптоПро
  2. Сайты гос органов.
  3. Возможность установить 1С
  4. Hasp ключики

Бухи особо не орут что интерфейс кривой :slight_smile:

Думают что Винда.

А если ворчат - сисадмины им говорят что новая версия винды 10 :slight_smile:

Но для себя я переделал

Не могу без верхней и нижней панели.

За много лет на кальке - привык

Что-то не загружается с флешки. А Etcher пишет, что загрузчик не найден.

Обновил сборку.
Исправлена ошибка загрузки с флешек.
https://ftp.linuxbuh.ru/distros/linuxbuh/lb-windows10-20210428-x86_64.iso
ftp://ftp.linuxbuh.ru/distros/linuxbuh/lb-windows10-20210428-x86_64.iso

Спасибо, заработало. А как криптопро установили?

Интересно ! в этой сборке будет работать NanoCAD CKC ???

Добрый день!
Попробовал эту сборку на G31-M-S2L, Core2Duo 2Ghz, 2,5Gb RAM, video Intel - работает хорошо, не вешает систему в отличие от сборки CLD.
Не могу обновить эту сборку, ругается:

(and 6 more with the same problem)

NOTE: Use the ‘–verbose-conflicts’ option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

!!! All ebuilds that could satisfy “>=dev-python/testtools-0.9.34[python_targets_python3_9(-)]” have been masked.
!!! One of the following masked packages is required to complete your request:

  • dev-python/testtools-2.4.0-r2::gentoo (masked by: EAPI 8)
  • dev-python/testtools-2.4.0-r2 (masked by: EAPI 8)

The current version of portage supports EAPI ‘7’. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by “dev-python/subunit-1.4.0::gentoo” [binary])
(dependency required by “net-fs/samba-4.13.9-r1::gentoo” [binary])
(dependency required by “net-libs/libsoup-2.72.0-r1::gentoo” [binary])
(dependency required by “xfce-extra/xfce4-screenshooter-1.9.9::gentoo” [binary])
(dependency required by “@selected” [set])
(dependency required by “@world” [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

  • Выполнение Emerge завершилось с ошибкой
  • Не удалось обновить

emerge -av1 portage
вывод:

Calculating dependencies | * ERROR: www-client/yandex-browser-beta-21.2.1.94::linuxbuh failed (depend phase):

  • EAPI=6 is not supported

и далее:

[binary NS ] dev-lang/python-3.9.5_p2:3.9::gentoo [2.7.18_p8:2.7::gentoo, 3.8.8_p1:3.8::gentoo] USE=“bluetooth gdbm ipv6 ncurses readline sqlite ssl xml -build -examples -hardened -test -tk -verify-sig -wininst (-libressl%)” 21359 KiB
[ebuild U ~] sys-apps/portage-3.0.19::gentoo [3.0.17-r2::gentoo] USE="(ipc) native-extensions xattr -apidoc -build -doc -gentoo-dev -rsync-verify (-selinux) -test" PYTHON_TARGETS=“python3_9* -pypy3 -python3_10% -python3_8* (-python3_7%)” 1317 KiB

Total: 2 packages (1 upgrade, 1 in new slot, 1 binary), Size of downloads: 22675 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/portage:0

(sys-apps/portage-3.0.19:0/0::gentoo, ebuild scheduled for merge) USE="(ipc) native-extensions xattr -apidoc -build -doc -gentoo-dev -rsync-verify (-selinux) -test" ABI_X86="(64)" PYTHON_TARGETS=“python3_9 -pypy3 -python3_10 -python3_8” pulled in by
sys-apps/portage[python_targets_python3_9] required by (sys-apps/calculate-utils-3.6.9.11:3/3::calculate, installed) USE=“backup client console dbus desktop gpg install qt5 -minimal -pxe (-server)” ABI_X86="(64)" PYTHON_TARGETS=“python2_7”
^^^^^^^^^^^^^^^^^^^^^^^^
sys-apps/portage (Argument)

(sys-apps/portage-3.0.17-r2:0/0::gentoo, installed) USE="(ipc) native-extensions xattr -apidoc -build -doc -gentoo-dev -rsync-verify (-selinux) -test" ABI_X86="(64)" PYTHON_TARGETS=“python3_8 (-pypy3) -python3_7 -python3_9” pulled in by
sys-apps/portage[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?] required by (app-portage/gentoolkit-0.5.0-r2:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS=“python3_8 (-pypy3) -python3_7 -python3_9”

© 2007-2020 Calculate Ltd.
Mastodon Mastodon