XFCE4 not starting desktop

Hello people,
i’am very impressed about “calculate-linux”
So installed XFCE4.
But after system upgrade, the system don’t start into the desktop.
The xserver starts into the blue calculate desktop whitout icons, then stops go back to console, it starts back to the blue screen, stops go back to console and so on.I have to start it by hand.Doing CTRL+Alt+F1, login as user, login as root, do /etc/init.d/xdm stop, then init 3, exit and finally startx by user.
I think i have done something wrong on “etc-update”
The same error on a second PC.


Hope someone can help

What videocard do you have? was kernel updating? Try <<emerge -a module-rebuild>>

I have a nvidia GTS250 installed, on latest calculate kernel.


Hello Ferdinand,

Which driver you are using : Nvidia manufacturer driver or Nouveau free driver ?


XKomodor | Julien

latest calculate-linux installs only with nouveau, when using nvidia, there is a kernel panic and the pc crashes, no more mouse and keyboard.Later i install Nvidia manufacturer driver.
I use calculate for some time now never had this problem.
The kernel and nvidia are ok i think.



Tonight, I installed calculate CLDX from Stable 13.19 with Nvidia driver and composite.

After upgrade with the latest version (x11-drivers/nvidia-drivers-340.24)

emerge @module-rebuild

And all work fine …

My hardware :
NVIDIA-SMI 340.24 / Driver Version: 340.24 / GeForce GTX 660

What is the ISO version you use ? Because yesterday, I use a “stage version” on the date of early August and I have a lot of strange behavior …


XKomodor | Julien

I also installed CLD from begin Aug yesterday on an other partition.On install same problems as above.
(crashing pc no mouse and keyboard)
So used nouveau.
I am busy for some time,
will give an answer when this is done



Try with the stable ISO and upgrade your system …


XKomodor | Julien

thanks for helping,
my system is very up to date(uDN world).Everything is working good also nvidia,only help2man and gutenprint won’t compile.
Reinstall CLDX-13.19 is no option.
Now i’am ugrading CLD, take some time.


emerge @module-rebuild
Did’nt help

Try to create new user and login to system. May be current user profile was corrupted.

The xserver starts into the blue

Probably video driver works good. Is there enough free space on the disk?

there is plenty of diskspace on every partition at least (200GB free) for each partition.
Have started a third install XFCE4 stable on an other partition.
System is very up to date, (uDN world)
So now my third attemp is succesfull, everything is normal and starts fine :wink:

maybe you can not have everything
but still traying to have nvidia running

Still problems,

Available kernel symlink targets:
[1] linux-3.16.3-gentoo *
calculate ferdi # eselect opengl list
Available OpenGL implementations:
[1] nvidia *
[2] xorg-x11NVID
calculate ferdi # glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:

works great!!!

but still the same starting problems as above on each (xfce4) of calculate systems.
(Doing CTRL+Alt+F1, login as user, login as root, do /etc/init.d/xdm stop, then init 3, exit and finally startx by user)

(my system is uDN world)
today (26/11/2014) 2 of 3 xfce4 calculate systems are starting normal!
calculate ferdi # eselect kernel list
Available kernel symlink targets:
[1] linux-3.17.4-gentoo *
calculate ferdi # eselect opengl list
Available OpenGL implementations:
[1] nvidia *
[2] xorg-x11
calculate ferdi # eselect opencl list
Available OpenCL implementations:
[1] mesa
[2] nvidia *
02:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce GTS 250] (rev a2)
Can’t go higher as
I had to remove “cuda” from “make.conf” to prevent update nvidia-drivers which do not work.
Is there a way stop upgrading higher then “nvidia-drivers-340.58” but still upgrading the system?

You can mask this packages. Add lines like this to <</etc/portage/package.mask/custom>>:

echo ">=x11-drivers/nvidia-drivers-340.58
>=media-video/nvidia-settings-340.58" >> /etc/portage/package.mask/custom