Calculate Forum

X wake-up issues with Nvidia GT1030

Hi there,
I have Nvidia card (MSI GT1030) and Gigabyte B450 board.
Installed CLD with nvidia binary drivers selected. I have two main problems now.

  1. After wakeup from suspend/sleep my X sometimes wont start, I can see the cursor, I can switch to tty1 and login but cannot see graphical login screen anymore.
    There is a also second,better scenario after wake-up, when I CAN log in to the system, but part of the content in the browser does not refresh properly and I see artifacts from older content.

  2. The X also randomly freezes during the computer run, and only way to solve it is to switch to ttyX and reboot the computer.
    Then I switch to the nouveau drivers in cl-console, but the problems with the wake-up was even worst - I can see the wallpaper but sddm wont start and I cant switch to the tty1 to reboot, so I must do hard reset.

To eliminate the hardware problems I reinstalled the same box with the KDE Neon, where everything seems to work just fine. It apparently is using the nouveau drivers, so I wonder where are the differences (except the obvious one like openRC vs systemd).

I really would like to stick with the CLD linux as it is my favorite distro but it is very difficult under the current circumstances. Can anybody help me to solve this?

1 Like

I have the same problem.
Nvidia card (ASUS GT640).
ASUS H67 board.

Hi,

Have you tried to use

cl-setup-video

command? I had a flickering issue after installing nvidia driver for Zotac Nvidia GT710 card but after running this command something in xorg.conf was changed and it works perfectly now.

Thanks for suggestion! I have tried cl-setup-video, however the results after the resume from sleep was that browset windows was totally black (I cant even see the window frame). But restarting the browser (vivaldi) did fix this problem.
What is important that I cant trust the system stability after the sleep/resume cycle like it was with the intel cards I used previously.
The nouveau drivers are lazy as hell, and the nvidia-drivers are fckn unstable for me.

1 Like

Yes, I also experience exactly the same problems on Firefox and Chrome after waking from sleep mode. I get a sneaky suspicion it has something to do with config_i2c_nvidia_gpu kernel module setting message I reported earlier here:

https://forum.calculate-linux.org/t/config-i2c-nvidia-gpu-nvidia/10288/5

This issue reminds me of OpenGL programming when a call to clear frame buffer had to be in order for animation to happen properly. Since the error message is GPU-related, maybe it’s the same type of a problem. Maybe Calculate devs could turn this module off with next kernel update (if this module setting is the cause of this problem)?

© 2007-2020 Calculate Ltd.
Mastodon Mastodon