Calculate Forum

Www-client/qutebrowser-1.10.1 stabilized breaks some dependencies like PyQt5

Hi!

qutebrowser 1.10.1 became stable in the Gentoo Tree (in Calculate), but it requires recent versions of packages like PyQt5.

You can see it below:

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-python/PyQtWebEngine-5.14.0::gentoo
# required by www-client/qutebrowser-1.10.1::gentoo
# required by @selected
# required by @world (argument)
=dev-python/sip-4.19.21 ~amd64
# required by www-client/qutebrowser-1.10.1::gentoo
# required by @selected
# required by @world (argument)
=dev-python/PyQtWebEngine-5.14.0 ~amd64
# required by www-client/qutebrowser-1.10.1::gentoo
# required by @selected
# required by @world (argument)
=dev-python/jinja-2.11.1 ~amd64
# required by www-client/qutebrowser-1.10.1::gentoo
# required by @selected
# required by @world (argument)
=dev-python/PyQt5-5.14.1 ~amd64
# required by www-client/qutebrowser-1.10.1::gentoo
# required by @selected
# required by @world (argument)
=dev-python/colorama-0.4.3 ~amd64
# required by dev-python/PyQtWebEngine-5.14.0::gentoo
# required by www-client/qutebrowser-1.10.1::gentoo
# required by @selected
# required by @world (argument)
=dev-python/PyQt5-sip-4.19.21 ~amd64

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-video/openshot-2.4.4-r1::gentoo[python_single_target_python3_6]
# required by @selected
# required by @world (argument)
>=dev-python/PyQt5-5.14.1 webkit

I hope this may be fixed soon.

Thank you!

© 2007-2020 Calculate Ltd.
Mastodon Mastodon