Calculate Forum

Wifi problem - connection randomly dropping

network

#1

Hi there, new Calculate Linux user here. I need some advise with this. My wireless connection keeps dropping with this error message from KDE Networkmanager: “authorization supplicant timed out”.

I’ve tryed this solution (found somewhere online), to no difference:

#echo "options iwlwifi 11n_disable=1 wd_disable=1" >> /etc/modprobe.d/iwlwifi.conf

Here’s some input that may help…

christian@calculate ~ $ lspci
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:04.0 Signal processing controller: Intel Corporation Device 0a03 (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
00:1f.6 Signal processing controller: Intel Corporation 8 Series Thermal (rev 04)
01:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

Wifi down:

christian@calculate ~ $ inxi -fxi
CPU:       Dual core Intel Core i5-4210U (-MT-MCP-) 
           arch: Haswell rev.1 cache: 3072 KB bmips: 9578
           clock speeds: max: 2700 MHz 1: 1053 MHz 2: 904 MHz 3: 1006 MHz
           4: 1175 MHz
           CPU Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2
           bmi1 bmi2 bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8
           de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c             
           flexpriority fma fpu fsgsbase fxsr ht ida invpcid invpcid_single     
           lahf_lm lm mca mce mmx monitor movbe msr mtrr nonstop_tsc nopl nx    
           pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse  
           pse36 pti pts rdrand rdtscp rep_good sdbg sep smep ss sse sse2       
           sse4_1 sse4_2 ssse3 syscall tm tm2 tpr_shadow tsc tsc_adjust vme     
           vmx vnmi vpid xsave xsaveopt xtopology xtpr                          
Network:   Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter   
           driver: ath9k bus-ID: 01:00.0                                        
           IF: wlan1 state: down mac: ca:ba:89:e0:e1:16                         
           Card-2: Qualcomm Atheros usb-ID: 001-005                             
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A            
           WAN IP: None Detected!                                               
           IF: wlan1 ip-v4: N/A ip-v6-link: N/A

and

christian@calculate ~ $ iwconfig
lo        no wireless extensions.

wlan1     IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=16 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

Wifi up

christian@calculate ~ $ inxi -fxi
CPU:       Dual core Intel Core i5-4210U (-MT-MCP-) 
           arch: Haswell rev.1 cache: 3072 KB bmips: 9578
           clock speeds: max: 2700 MHz 1: 1000 MHz 2: 1208 MHz 3: 1620 MHz
           4: 1594 MHz
           CPU Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2
           bmi1 bmi2 bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8
           de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c
           flexpriority fma fpu fsgsbase fxsr ht ida invpcid invpcid_single
           lahf_lm lm mca mce mmx monitor movbe msr mtrr nonstop_tsc nopl nx
           pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse
           pse36 pti pts rdrand rdtscp rep_good sdbg sep smep ss sse sse2
           sse4_1 sse4_2 ssse3 syscall tm tm2 tpr_shadow tsc tsc_adjust vme
           vmx vnmi vpid xsave xsaveopt xtopology xtpr
Network:   Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
           driver: ath9k bus-ID: 01:00.0
           IF: wlan1 state: up mac: 38:b1:db:cd:55:33
           Card-2: Qualcomm Atheros usb-ID: 001-005
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
           WAN IP: 191.209.110.52
           IF: wlan1 ip-v4: 192.168.0.23 ip-v6-link: fe80::4f92:239e:8406:1f79

and

christian@calculate ~ $ iwconfig
lo        no wireless extensions.

wlan1     IEEE 802.11  ESSID:"Terceiro_"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 64:70:02:54:36:3A   
          Bit Rate=150 Mb/s   Tx-Power=16 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=67/70  Signal level=-43 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:2  Invalid misc:12   Missed beacon:0

Can anyone help?