Calculate🐧Forum

Vivaldi et les DRM

#1

Salut Ă  tous,

AprĂšs avoir visionnĂ© un des multiples vidĂ©os de Adrien, j’ai remarquĂ© qu’il utilise comme navigateur Vivaldi alors je l’ai installĂ© et je dois dire que j’ai Ă©tĂ© bluffĂ© par son ergonomie, l’interface et sa rapiditĂ©. J’adore son interface moderne et esthĂ©tique.

Le seul gros problĂšme avec Vivaldi est la gestion de contenu protĂ©gĂ© soit les fameux DRM. Sous Firefox et Chrome le problĂšme ne se pose pas. Mais c’est le seul problĂšme qui me reste Ă  rĂ©soudre sous vivaldi. Il semble que ce problĂšme est sous linux seulement avec Vivaldi. Mais comme il est basĂ© sur chrome en thĂ©orie on s’attendrais Ă  ne pas rencontrer ce problĂšme.

J’ai essayĂ© quelques solution trouvĂ© ici et lĂ  mais rien Ă  faire sous vivaldi ça fonctionne pas. Les codec ffmpeg sont bien installĂ©. La solution se trouverait peut-ĂȘtre avec le paquet suivant:

<> n’est pas disponible sous gentoo. Et si on fait la recherche sur gentoo packages, on a Nothing found. :frowning: Try again? comme rĂ©ponse de recherche.

Alors est-ce qu’il y a un d’entre-vous qui a trouvĂ© une solution ?

Merci à l’avance

Version installé 2.3.14 stable site de test icitou.tv

#2

Bonjour,

Je crois que tu peux ajouter l’adrien-overlay https://github.com/aaaaadrien/adrien-overlay, et installer www-misc/get-ffmpeg-vivaldi. Ensuite, tu dois simplement faire la commande :

get-ffmpeg-vivaldi stable

Tu peux remplacer stable par snapshot pour la version snapshot de vivaldi.

#3

Bonjour,

Merci de votre rĂ©ponse
 Je vais testĂ© ça et je vous reviens pour le rĂ©sultat !

#4

Alors voici,

L’Installation s’est dĂ©roulĂ© parfaitement ! Mais cela ne rĂ©gle pas le problĂšme de DRM


Il semble que Vivaldi sous Linux ne gĂšre pas encore. Sous Win et Mac pas de soucis semble t’il mais je n’ai pas testĂ©. Je suis sous linux depuis 20 ans.

Donc je vais attendre les prochaines version de Vivaldi

Si jamais quelqu’un a trouvĂ© et bien je serais preneur


Merci

#5

Oui, je viens également de vérifier, et le problÚme est toujours là.

Je pensais que get-ffmpeg-vivaldi rĂ©glait l’ensemble des problĂšmes, mais ce n’est pas le cas. Ça rĂšgle nĂ©anmoins certains problĂšmes, car il y a des vidĂ©os que je ne pouvais pas regarder qui sont maintenant fonctionnelles.

J’ai trouvĂ© un article de blog https://vivaldi.com/blog/vivaldi-update-focus-on-details/ qui stipulait que Widevine Ă©tait maintenant prĂ©sent dans Vivaldi Linux. Toutefois, il semble y avoir eu un problĂšme https://vivaldi.com/blog/snapshots/qa-monkey-makes-mistake/; je ne sais pas si, ultimement, cela va rĂ©gler le problĂšme 


#6

Effectivement avant de faire mon post ici j’ai lu Ă©galement certain article. Mais ce n’est pas trĂšs clair sur le forum de Vivaldi !

A suivre donc merci

#7

Bon, j’ai peut-ĂȘtre trouvĂ© une solution temporaire. Juste mentionner que j’ai simplement testĂ© sur ici.tou.tv, car je n’ai pas d’abonnement sur des sites comme Netflix. Aussi, j’ai tentĂ© plusieurs procĂ©dures, alors il est possible qu’il faille rajouter des Ă©tapes, mais je crois que tu peux installer chrome-binary-plugins (avec le flag widevine), et ensuite crĂ©er un lien avec libwidevinecdm.so :

 emerge -av chrome-binary-plugins 

  ln -fs /usr/lib/chromium-browser/libwidevinecdm.so /opt/vivaldi/libwidevinecdm.so 

Si tu pouvais confirmer que cela fonctionne sur ici.tout.tv, et peut-ĂȘtre sur d’autres sites, cela pourrait ĂȘtre intĂ©ressant.

#8

Bonjour Jesse,

J’ai essayĂ© votre solution (sur laptop lenovo config intel) cela ne corrige pas le problĂšme sur icitou.tv. Moi non plus je n’ai pas de compte netflix alors je ne peu pas testĂ©. Je vais essayer sur mon Desktop ce weekend peut-ĂȘtre que ça va fonctionner.

A suivre

#9

Salut Jesse,

J’ai effectuĂ© la mĂȘme manoeuvre sur mon Desktop et le rĂ©sultat est le mĂȘme que sur le laptop. Vivaldi ne gĂšre pas nativement les DRM sous linux seulement. On aura essayé 

Conclusion: Vivaldi superbe ergonomie, rapide mais pratiquement inutile dans un contexte d’utilisation multimĂ©dia.

Merci

Mastodon Mastodon