Calculate Forum

Viber in Calculate

Версия пакета viber, 7, не работает. Невозможно войти. Скоро ли выйдет новая версия пакета Viber, в других дистрибутивах это версия 12?

Это только ебилд 7-ой версии, скачивается deb с сайта вайбера, без указания версии, последний доступный, сейчас у меня 12.0.0.

#rm /var/db/repos/calculate/net-im/viber/Manifest
#ebuild /var/db/repos/calculate/net-im/viber/viber-7.0.0.1035-r2.ebuild digest
#FEATURES="-getbinpkg" emerge viber

Если ставить из бинарников, то будет 10.3.0.
Обе работают и коннектятся нормально. Хотя более свежая и кушает ресурсы серьёзно приличнее.

Теперь уже правильней в локальный оверлей перенести:

mkdir -p /var/calculate/custom-overlay/net-im/viber
cd /var/calculate/custom-overlay/net-im/viber
cp -r /var/db/repos/calculate/net-im/viber/* .
mv viber-7.0.0.1035-r2.ebuild viber-12.0.0.ebuild
ebuild viber-12.0.0.ebuild digest
emerge -a viber

или дождаться обновления ebuild-а.

Спасибо @RodionD, @Lautre. Пакет Viber установлен, но не имеет графического окружения.

/opt/viber/viber %u
Attribute Qt::AA_ShareOpenGLContexts must be set before QCoreApplication is created.
ICE default IO error handler doing an exit(), pid = 6606, errno = 32
QMutex: destroying locked mutex
QMutex: destroying locked mutex
malloc(): smallbin double linked list corrupted
Aborted

Подождите несколько часов пока обновятся зеркала и попробуйте поставить из оверлея. Я попробовал - работает.

Спасибо за помощь, я сделаю это.

Просто версия ебилда вообще не соответствует версии того deb-а, что она должна скачивать, да и с каждой новой версией меняется размер, а значит будет проблема с манифестом, этот ебилд нужно переписать, что бы у него были “плавающие” исходники, без фиксации их размера в манифесте, типа гитовских и версия тогда 999 была бы в самый раз. :slight_smile:

Да, наверное, единственно 999 бы всех пугала )

я как-то с зугаины 9999 ставил. поседел во всех местах.)

Я недавно обновлял viber, сейчас 12.0.0 - работает.

[I] net-im/viber [1]
     Доступные версии:      12.0.0^msd{tbz2} {+apulse}
     Установленные версии:  12.0.0^msd{tbz2}(15:23:04 10.01.2020)(apulse)

Я попробовал Calculate mate, lxqt, и Viber работает, он просто не работает на xfce, это потому, что я стар и безобразен. Viber был напуган.

Я решил проблему. Viber не работает с драйверами Nouveau, он отлично работает с проприетарными драйверами Nvidia.

вайбер с нуво работает. проверено лично мною в течение 2-3 лет.

Он также работал со мной до последней версии, версии 12. В версии 12 он работает с проприетарными драйверами.

Mastodon Mastodon