USB Volume Knob Issue


I use a USB volume knob for my audio control and it works well with the LiveCD but nothing after install. I tried two installs. One with Alsa (current), and Pipewire. Both have the same result (but Alsa does have substantially less background noise).

$ lsusb results show it exists
Bus 006 Device 002: ID 0440:5050 Eizo Nanao Corp. USB-volume

In all of the Audio/Sound controls I can find, it does not exist, and the speaker in the top bar has red line through it (not muted - when clicked it says “No output or input devices found”).

YouTube and music play fine (just loud with no way to turn it down) even though it says no audio found.

$ lspci results shows several sound devices but I use the Intel onboard.
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller

Did I miss something during install that would have skipped the modules to handle my sound and USB volume control knob?

The knob does allow my to press it down to pause/play video so it must be showing up somewhere, I just do not know what to configure to get it accepted.

Any assistance is appreciated.

Try check your /etc/group for audio usb (for your_login).
Perhaps you do not have access to either audio or USB.

2-nd variant

Boot with LiveCD (livedvd)
- run:
# lsmod
-save this list anythere

-Boot from install System
# lsmod
-save this list again anythere

and study who is present and especially who is absent

Hello! :slight_smile:
I am all added to those groups (and more).

I’ll go work the lsmod route next and see what might have changed between install and boot up.

Thank you so much for the ideas, I’m still really enjoying this distro.

Hello! :slight_smile:

I like this troubleshooting stuff because I learned some new stuff.

I learned how to use comm and diff a little more.

Here are the lsmod items that are not in the current install (but are in the liveDVD environment:


I will start searching now, but I am not sure I remember how to load modules in Gentoo (Calculate). It seems strange some of them are missing like "overlay, snd_hda_condeccat, and sqashfs.

Thank you for the ideas.

overlay, squashfs, udf - it’s only for liveDVD
bnep, rfcomm - for bluetooth
snd_hda_codeccat - !
I think this kernel module solves your problem.
BUT i try
# modinfo snd_hda_codeccat
modinfo: ERROR: Module snd_hda_codeccat not found.
# modprobe snd_hda_codeccat
modprobe: FATAL: Module snd_hda_codeccat not found in directory /lib/modules/6.6.22-calculate

What version of liveDVD do you have?
And , please, your (liveDVD & install system) ‘uname -a’

I have no idea what it is doing under the hood (behind the scenes) but I have re-installed a few times (Tried Redcore Linux also, but that is one ugly distro and apparently doesn’t theme very easily - so, no).

I gave Cinnamon a try (I am a Gnome fan) but I didn’t feel comfy in it. Now I am back to regular Calculate Linux KDE and it is all working well (sound included).

I have also been trying to figure out how Calculate Linux handles use flags, autounmasking, and if it is safe to go back to source based installation (I like installing from source, thus my love of Gentoo). I had to add some use flags (/etc/portage/package.use/firefox) because I am using the nouvou drivers and there is a bug with Firefox vs hdaccel and nouvou drivers.

Anyhow, really wonderful distro with an easy installer (could use better control of partitioning).

Keep on keeping on … great work and I really appreciate the distro! :slight_smile: :smiley: