Calculate🐧Forum

update impossible Linux calculate 4.18.12-calculate MATE / emerge echoué

#1

Bonjour,

Apres avoir essayer a travers l’interface graphique de faire une update qui a Ă©chouĂ©e je suis passe en ligne de commande et mĂȘme rĂ©sultat.

Probleme:

  • Error: The above package list contains packages which cannot be
    * installed at the same time on the same system.

(sys-power/powermgmt-base-1.31:0/0::gentoo, binary scheduled for merge) pulled in by

=sys-power/powermgmt-base-1.31 required by (sys-apps/apmd-3.2.2_p14-r1:0/0::gentoo, ebuild scheduled for merge)

(sys-power/pm-utils-1.4.1-r7:0/0::gentoo, binary scheduled for merge) pulled in by
sys-power/pm-utils required by (sys-auth/consolekit-1.2.1:0/0::gentoo, binary scheduled for merge)

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages
* Emerge a échoué
* Mise à jour échouée

Je n’arrive pas a m’en sortir en jouant avec le custom sous /etc/portage/package.mask

Merci d’avance

#2

Pb resolu

#3

salut comme t’on probleme est rĂ©solu il ne sera pas nĂ©cessaire de te donner le lien de ma mĂ©saventure qui ressemble trait pour trait a t’on probleme
amicalement

#4

Unfortunately I’ve faced the same issue with blocked packages during update. And there is my solution. As sys-power/powermgmt-base is an indirect dependency of mate-base/mate-applets-1.20.2_rc73, then what we can do with that:

# install mate-base/mate-applets-1.20.2 which does not depend on sys-power/powermgmt-base
emerge =mate-base/mate-applets-1.20.2

# fix the version of mate-base/mate-applets-1.20.2
# add a line to /etc/portage/profile/package.provided
echo “mate-base/mate-applets-1.20.2” >> /etc/portage/profile/package.provided

# perform update
cl-update

Mastodon Mastodon