Calculate Forum

Сглаживание шрифтов

#1

Сегодня комрад поделился полезной ссылкой, суть в заголовке, содержание вот…
Подключаем нужный оверлей:

layman -a lcd-filtering

Определяем USE:

euse -D cleartype
euse -E lcdfilter

Обновляем пакеты с новыми USE:

emerge -uDNav --autounmask-write world
etc-update
emerge -uDNav world

Перезапустить иксы…

P.S. скрины не привожу, пост не тянет на эти труды, лень пересобирать обратно пакеты, что бы показать разницу ДО и ПОСЛЕ… на словах - разница ощутима.

источник

#2

Спасибо. Круто

#3

Похоже нужна более тонкая настройка.
Пока получилось так, что буквы начали разъезжаться/наезжать друг на друга.

Это например в writer. В остальном между символами где-то на один пиксель расстояние стало больше, где-то меньше.

#4

Денис Жданов писал(а):

Похоже нужна более тонкая настройка.
Пока получилось так, что буквы начали разъезжаться/наезжать друг на друга.

Это например в writer. В остальном между символами где-то на один пиксель расстояние стало больше, где-то меньше.

Вот как это выглядит у меня
Можно подобрать шрифт и хинтинг, а так же размер шрифта может повлиять на качество, у меня например буква “р” немного смещалась то в лево то в право…
P.S. http://www.calculate-linux.ru/blogs/ru/316/show , media-fonts/dejavu, media-fonts/liberation-fonts, media-fonts/paratype, media-fonts/ubuntu-font-family (на мой вкус эти шрифты заслуживают внимания).

#5

Aleksey Vasilyevich писал(а):

Вот как это выглядит у меня

У меня что-то похожее, как на картинке вкладка “Rab o ta”. Расстояние между символами плавает.

#6

Денис Жданов писал(а):

Aleksey Vasilyevich писал(а):

Вот как это выглядит у меня

У меня что-то похожее, как на картинке вкладка “Rab o ta”. Расстояние между символами плавает.

Попробуй закоментить все строки в ~/.gtkrc-2.0 и /etc/gtk-2.0/gtkrc или удалить эти файлы… перезапусти иксы…
РЕЗУЛЬТАТ

#7

Aleksey Vasilyevich писал(а):

Попробуй закоментить все строки в ~/.gtkrc-2.0 и /etc/gtk-2.0/gtkrc или удалить эти файлы… перезапусти иксы…

У меня kde. Я попробовал различные шрифты, пока мне больше нравятся шрифты cld по умолчанию. Полностью избавиться от разъезжающихся символов не получилось.

#8

Более правильно устанавливать всё же как на wiki проекта
http://gitorious.org/lcd-filtering/pages/Install
Там же и настройка шрифтов. В общем лучше прочитать всё, это не долго
http://gitorious.org/lcd-filtering/pages/Home

#9

мне очень помогло.

#10

а мне помогло eselect fontconfig enable {1…32}

  • установка виндовых шрифтов.
#11

А по мне, так Droid Sans и никаких гвоздей… красиво, сглаживание везде, в терминале Droid Mono…

#12

Мне помогло дополнительно отключение USE флага bindist для freetype фонты перестали мылиться. Хотя не могу сказать, что результат меня полностью устроил, но выглядит всё уже гораздо лучше, чем было.

Mastodon Mastodon