Calculate Forum

Использование оверлей. Установка "Яндекс.Браузер"

Использование оверлей. Установка “Яндекс.Браузер” (https://browser.yandex.ru)
Дата составления описания: 2018.04.15
Дата последнего изменения описания: 2018.04.28
Нижеуказанные номера версий ПО соответсвуют дате последнего изменения данного описания.

Версии используемых OS: CLD, CLDC, CLDM, CLDX v.17.12 - 17.12.2
Версия “Яндекс.Браузер” официальная: 18.3.1 (https://browser.yandex.ru/beta/)
Описание оверлея “yandex” : команда ‘layman -i yandex’
Содержимое оверлея “yandex”:
“www-client/yandex-browser-beta ~18.3.1.1122_p1”
“www-plugins/yandex-browser-ffmpeg-codecs ~64.0.3282.186”

# cl-update --sync-only
# layman -L
# layman -i yandex
# layman -l
# layman -f -a yandex
# layman -l
# eix-sync
# eix -v yandex
# emerge -pv www-client/yandex-browser-beta
# emerge -bkv --ask www-client/yandex-browser-beta (см. Примечание 1)

Дополнительно можно установить плагин “yandex-browser-ffmpeg-codecs”.
Владельцам “слабых” ПК необходимо учесть, что процесс компиляции/установки “yandex-browser-ffmpeg-codecs” длительный и ресурсоёмкий:
# emerge -pv www-plugins/yandex-browser-ffmpeg-codecs
# emerge -bkv --ask www-plugins/yandex-browser-ffmpeg-codecs (см. Примечание 1)

Примечание 1.
Процесс установки может(?) запросить загрузку содержимого каталога “package.keywords”. В этом случае выполнить:
# touch /etc/portage/package.keywords/custom
# sudo emerge --autounmask-write -v www-client/yandex-browser-beta
(# sudo emerge --autounmask-write -v www-plugins/yandex-browser-ffmpeg-codecs)
# dispatch-conf
Вывод выполнения команды ‘dispatch-conf’:

(1 of 1) – /etc/portage/package.keywords/custom
q quit, h help, n next, e edit-new, z zap-new, u use-new
m merge, t toggle-merge, l look-merge:
Ответить: u
После загрузки содержимого каталога “package.keywords” необходимо повторно запустить процесс установки:
# emerge -bk --ask www-client/yandex-browser-beta
(# emerge -bkv --ask www-plugins/yandex-browser-ffmpeg-codecs)

Примечание 2.
При первом запуске “Яндекс.Браузер” запросит настройку. Один из параметров - “Использовать по умолчанию”. В KDE браузер повторно запрашивает “Использовать по умолчанию” даже после настройки (при повторных запусках браузера). Простой способ исправить это:

  1. В текcт.редакторе создайте и сохраните любой пустой документ в формате HTML (или сохраните страницу из итернет).
  2. Правой кнопкой мыши на файле HTML, “Открыть с помощью…”, “В другой программе…”.
  3. В открывшемся диалоговом окне выберите “Yandex Browser” и “Запомнить связь с приложением…”.
  4. Подтвердите “OK”.
    Владельцам “слабых” ПК необходимо учесть, что в “Яндекс.Браузер” по умолчанию интегрировано много дополненией. Например - блокировщики рекламы, сетевые заметки Everinote, менеджер паролей LastPass, сервисы Яндекс (Почта, Турбо, Погода, Пробки…). Каждый из этих плагинов потребляет ресурсы ПК, а все вместе они существенно замедляют работу браузера. Зайдите в меню браузера “Настройки”, “Дополнения”, включите лишь востребованные вами, остальные отключите.

При установке использовалась официальная “Документация Calculate Linux” (https://www.calculate-linux.ru/main/ru/documentation):

ya-brws--Set_as_default.png
layman–ya-brws–install_instructions.txt (4.75 KB)
layman–ya-brws–install_log.log (11.4 KB)
ya-brws--scr_sh_2018-04-20_15-08-04.jpg
ya-brws--scr_sh_2018-04-20_15-15-53.png
ya-brws--scr_sh_2018-04-20_15-28-06.jpg

Не собирается yandex-browser-ffmpeg-codecs, вылетает по ошибке:

obj/third_party/libdrm/libdrm/xf86drm.o: In function `drmOpenWithType':
xf86drm.c:(.text+0x6ea): undefined reference to `makedev'
obj/third_party/libdrm/libdrm/xf86drm.o: In function `drmOpenByBusid':
xf86drm.c:(.text+0x9aa): undefined reference to `makedev'
obj/third_party/libdrm/libdrm/xf86drm.o: In function `drmGetNodeTypeFromFd':
xf86drm.c:(.text+0x4203): undefined reference to `major'
xf86drm.c:(.text+0x4211): undefined reference to `minor'
obj/third_party/libdrm/libdrm/xf86drm.o: In function `drmGetMinorNameForFD':
xf86drm.c:(.text+0x446d): undefined reference to `major'
xf86drm.c:(.text+0x447e): undefined reference to `minor'
obj/third_party/libdrm/libdrm/xf86drm.o: In function `drmGetDevice2':
xf86drm.c:(.text+0x47dc): undefined reference to `major'
xf86drm.c:(.text+0x47ed): undefined reference to `minor'
xf86drm.c:(.text+0x4953): undefined reference to `major'
xf86drm.c:(.text+0x4964): undefined reference to `minor'
obj/third_party/libdrm/libdrm/xf86drm.o: In function `drmGetDevices2':
xf86drm.c:(.text+0x5cca): undefined reference to `major'
xf86drm.c:(.text+0x5cda): undefined reference to `minor'
obj/third_party/libdrm/libdrm/xf86drm.o: In function `drmGetDeviceNameFromFd2':
xf86drm.c:(.text+0x5ef7): undefined reference to `major'
xf86drm.c:(.text+0x5f08): undefined reference to `minor'
clang-6.0: error: linker command failed with exit code 1 (use -v to see invocation)

Никто с таким не сталкивался ?

Александр, если не удалось собрать “yandex-browser-ffmpeg-codecs”, пока попробуйте “подложить” его вручную, распаковав соответствующий deb-пакет. Подробная процедура описана по адресу: https://yandex.ru/support/browser-beta/working-with-files/video.html#problems__video-linux .
Прим. Ссылкой на данные ресурс завершается процедура установки “yandex-browser-beta”.

Добрый день!
Аналогично не собирается, пробовал разбираться ставить не достающие пакеты. Помогает но опять ошибки идут. Скрипт обновления в папке opt яндекаса, тоже ошибку показывает. Что конкретно за файл нужно руками из deb пакета скопировать?

Добрый день. Сборка cldc-20211019-x86_64.
Столкнулся с ошибкой после команды. (пока пользуюсь запуском из распаковки deb, но хотелось бы установить правильно, чтобы в меню появился браузер)

emerge -pv www-client/yandex-browser-beta

Calculating dependencies / * ERROR: www-client/yandex-browser-beta-20.8.0.864_p1::yandex failed (depend phase):
 *   chromium-2: EAPI=6 is not supported
 * 
 * Call stack:
 | *                                  ebuild.sh, line 645:  Called source '/var/lib/layman/yandex/www-client/yandex-browser-beta/yandex-browser-beta-20.8.0.864_p1.ebuild'
 *   yandex-browser-beta-20.8.0.864_p1.ebuild, line   6:  Called inherit 'chromium-2' 'unpacker' 'pax-utils' 'xdg-utils'
 *                                  ebuild.sh, line 329:  Called __qa_source '/usr/portage/eclass/chromium-2.eclass'
 *                                  ebuild.sh, line 114:  Called source '/usr/portage/eclass/chromium-2.eclass'
 *                          chromium-2.eclass, line  14:  Called die
 * The specific snippet of code:
 *   	*) die "${ECLASS}: EAPI=${EAPI:-0} is not supported" ;;
 * 
 * If you need support, post the output of `emerge --info '=www-client/yandex-browser-beta-20.8.0.864_p1::yandex'`,
 * the complete build log and the output of `emerge -pqv '=www-client/yandex-browser-beta-20.8.0.864_p1::yandex'`.
 * Working directory: '/usr/lib/python3.9/site-packages'
 \ * S: '/var/calculate/tmp/portage/www-client/yandex-browser-beta-20.8.0.864_p1/work/yandex-browser-beta-20.8.0.864_p1'
 | * ERROR: www-client/yandex-browser-beta-20.4.3.268_p1::yandex failed (depend phase):
 *   chromium-2: EAPI=6 is not supported
 * 
 * Call stack:
 *                                  ebuild.sh, line 645:  Called source '/var/lib/layman/yandex/www-client/yandex-browser-beta/yandex-browser-beta-20.4.3.268_p1.ebuild'
 *   yandex-browser-beta-20.4.3.268_p1.ebuild, line   6:  Called inherit 'chromium-2' 'unpacker' 'pax-utils' 'xdg-utils'
 \ *                                  ebuild.sh, line 329:  Called __qa_source '/usr/portage/eclass/chromium-2.eclass'
 *                                  ebuild.sh, line 114:  Called source '/usr/portage/eclass/chromium-2.eclass'
 *                          chromium-2.eclass, line  14:  Called die
 * The specific snippet of code:
 *   	*) die "${ECLASS}: EAPI=${EAPI:-0} is not supported" ;;
 * 
 * If you need support, post the output of `emerge --info '=www-client/yandex-browser-beta-20.4.3.268_p1::yandex'`,
 * the complete build log and the output of `emerge -pqv '=www-client/yandex-browser-beta-20.4.3.268_p1::yandex'`.
 * Working directory: '/usr/lib/python3.9/site-packages'
 * S: '/var/calculate/tmp/portage/www-client/yandex-browser-beta-20.4.3.268_p1/work/yandex-browser-beta-20.4.3.268_p1'
... done!

!!! All ebuilds that could satisfy "www-client/yandex-browser-beta" have been masked.
!!! One of the following masked packages is required to complete your request:
- www-client/yandex-browser-beta-20.8.0.864_p1::yandex (masked by: corruption)
- www-client/yandex-browser-beta-20.4.3.268_p1::yandex (masked by: corruption)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Оверлей Yandex давно не обновлялся :joy: его хозяин куда-то пропал
Создал свой https://github.com/linuxbuh/linuxbuh/tree/master/www-client/yandex-browser-beta

использование и подключение https://linuxbuh.ru/docs/dokumentacziya-po-distributivam-proek/obshhaya-dokumentacziya-dlya-vseh-distribu/overlay-linuxbuh-ru/

на текущий момент версия www-client/yandex-browser-beta-21.8.3.767

www-plugins/yandex-browser-ffmpeg-codecs пока не работает - надо разбираться

1 Like

Устанавливаю yandex, пишет ошибку:

calculate linux # emerge www-client/yandex-browser-beta

Local copy of remote index is up-to-date and will be used.

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) www-client/yandex-browser-beta-21.9.1.600::linuxbuh
>>> Installing (1 of 1) www-client/yandex-browser-beta-21.9.1.600::linuxbuh
>>> Jobs: 1 of 1 complete                           Load avg: 2.14, 1.17, 0.89

 * Messages for package www-client/yandex-browser-beta-21.9.1.600:

 * Could not detect kernel version.
 * Please ensure that /usr/src/linux points to a complete set of Linux sources.
 * Unable to calculate Linux Kernel version for build, attempting to use running version

Вывод:

calculate src # ls -l /usr/src/linux
lrwxrwxrwx 1 root root 22 ноя 29 19:06 /usr/src/linux -> linux-5.15.4-calculate
calculate src # eselect kernel list
Available kernel symlink targets:
  [1]   linux-5.15.4-calculate *
сalculate src # eix -I sources
[I] sys-kernel/calculate-sources [1]
     Доступные версии:      
     (5.10.73) 5.10.73^bs{tbz2}
     (5.10.81) ~5.10.81^bs
     (5.14.21) ~5.14.21^bs
     (5.15.4) (~)5.15.4^bs{tbz2}
       {build desktop firmware fsync +grub minimal muqss symlink themes uksm +vmlinuz KERNEL="linux"}
     Установленные версии:  5.15.4(5.15.4)^bs{tbz2}(23:11:19 21.11.2021)(desktop firmware grub minimal symlink themes vmlinuz -build -fsync -uksm KERNEL="linux")
     Домашняя страница:     http://www.calculate-linux.org
     Описание:              Calculate Linux kernel image

[I] virtual/linux-sources
     Доступные версии:      3-r6 3-r11[1] {firmware}
     Установленные версии:  3-r11[1](08:28:20 09.03.2021)
     Описание:              Virtual for Linux kernel sources

[1] "calculate" /var/db/repos/calculate

Найдено 2 совпадение.

PS: выяснил что мешал Касперский, удалил, переустановил исходники и снова поставл яндекс браузер, но после установки ошибок не было, но программа не запускается

calculate user # emerge www-client/yandex-browser-beta

Local copy of remote index is up-to-date and will be used.

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) www-client/yandex-browser-beta-21.9.1.600::linuxbuh
>>> Installing (1 of 1) www-client/yandex-browser-beta-21.9.1.600::linuxbuh
>>> Jobs: 1 of 1 complete                           Load avg: 1.61, 1.67, 1.32

 * Messages for package www-client/yandex-browser-beta-21.9.1.600:

 * For a complete support of videoudio in the HTML5 format
 * emerge an ebuild 'www-plugins/yandex-browser-ffmpeg-codec'.
 * For more info see: https://yandex.ru/support/browser-beta/working-with-files/video.html#problems__video-linux
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

Снимок экрана_2021-11-29_21-36-57

Это не официальный репозиторий.
А что скажет консоль при запуске?

Официальный давно протух к сожалению.

А вообще этот файл есть в /usr/bin ? может быть пакет кривой

нет файла нет, видимо пакет кривой в репозитории linuxbuh

Как вариант: поискать его в /opt
А фапче:
‘find / -name yandex-browser-beta’
или
/var/db/pkg/www-client/ _{YB}- /CONTENTS
Там исчо болче инфы для …
… бога Инфы?

Скачал дебку. Посмотрел. Да, в /usr/bin/ распаковывается ссылка на /opt – по идее. Видимо в конкретном случае - не создалась.

Да, руками сделал - всё заработало.

yandex обновил версию файла установки, теперь автоматом из репа Linuxbuh не ставиться

Самое простое решение

ln -s /opt/yandex/browser-beta/yandex-browser-beta /usr/bin/yandex-browser-beta

Обновил ebuild до версии 21.9.1.600

Я уже давно ручками распаковываю deb-ки. Можно надеяться, что Вы будете обновлять билд регулярно?

“Надеяться можно только на мощъ Великого Кес**я”.
Результат нестабилен.
Пока можно продолжать ручками, но и СЛЕДИТЬ не только за официальными инфами про обновы, НО и за КАЖДЫМ файлом апдейта, ибо Емерже за Этим следить уже не сможет.
(какроч где-то есть правило генту с однёрками и четвёрками - и приводит оно к - ССЗБ)

PS: скорее Менее, но тем не менее: ИМХО более правильное решение - повысить свой скилл в области генты/кальки - и вести свой оверлей как необязательную запасную альтернативу.

Насколько хватит времени. Иногда не уследишь - yandex мне не сообщает об обновах :joy:

Тоже вариант :grinning:

Может напишем в яндекс каждый по письму, просим создать или курировать маленький оверлей с браузером и диском.
я сейчас скачиваю deb смотрю внутри на строку Version в файле control/control, ищу на gpo.zugaina.org максимально свежий ebuild. Потом перекидываю в локальный оверлей с переименованием на текущую версию, потом пересоздаю манифест и, наконец-то, устанавливаю штатно… Вопросы бывают с кривыми ebuild’ами…

© 2007-2020 Calculate Ltd.
Mastodon Mastodon