Не обновляется система

Не обновляется система.Вот выхлоп в терминале

Синхронизация репозиториев
 * Синхронизация Distros репозитория ...                                                    [ ok ]
 * Синхронизация Calculate репозитория ...                                                  [ ok ]
 * Синхронизация Portage репозитория ...                                                    [ ok ]
 * Обновление кэша Distros репозитория ...                                                  [ ok ]
 * Обновление кэша Calculate репозитория ...                                                [ ok ]
 * Обновление кэша eix ...                                                                  [ ok ]
 * Удаление устаревших архивов и бинарных пакетов ...                                       [ ok ]
 * Синхронизация завершена
Конфигурация системы
 * Исправление настроек ...                                                                 [ ok ]
 * Обновление конфигурационных файлов ...                                                   [ ok ]
Проверка обновлений
 * Вычисление зависимостей ...                                                              [ ok ]

!!! Problem resolving dependencies for x11-drivers/nvidia-drivers from @selected
... готово!

!!! The ebuild selected to satisfy "x11-drivers/nvidia-drivers" has unmet requirements.
- x11-drivers/nvidia-drivers-346.35::gentoo USE="X acpi multilib tools -gtk2 -gtk3 -pax_kernel -uvm" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    tools? ( any-of ( gtk2 gtk3 ) )

  The above constraints are a subset of the following complete expression:
    tools? ( X any-of ( gtk2 gtk3 ) )

(требуется по зависимости для "@selected" [комплект])
(требуется по зависимости для "@world" [аргумент])
 * Выполнение Emerge завершилось с ошибкой
 * Не удалось обновить

как лечить кто знает?

Та же картина. Разница только в том, что вместо nvidia
!!! Problem resolving dependencies for www-plugins/adobe-flash from @selected
… готово!

Дмитрий Полт wrote:

Не обновляется система.Вот выхлоп в терминале
[…]

как лечить кто знает?

 The following REQUIRED_USE flag constraints are unsatisfied:
    tools? ( any-of ( gtk2 gtk3 ) )

  The above constraints are a subset of the following complete expression:
    tools? ( X any-of ( gtk2 gtk3 ) )

говорит о том, что при использовании флага tools надо еще включить флаг gtk2 или gtk3

не, понятно, что надо включить.
вопрос в ином == самому флаги прописывать или очередное обновление ждать?

Обновление уже пришло )

да, чудесным образом минут 40 назад все “починилось”. спасибо.

Обновление не пошло.
!!! Problem resolving dependencies for www-plugins/adobe-flash from @selected
… готово!

!!! The ebuild selected to satisfy “www-plugins/adobe-flash” has unmet requirements.

  • www-plugins/adobe-flash-11.2.202.440::gentoo USE="-debug -kde (-selinux)" CPU_FLAGS_X86="-sse2"

The following REQUIRED_USE flag constraints are unsatisfied:
cpu_flags_x86_sse2

The above constraints are a subset of the following complete expression:
cpu_flags_x86_sse2 debug? ( abi_x86_32 ) any-of ( abi_x86_64 abi_x86_32 )

(требуется по зависимости для “selected" [комплект]) (требуется по зависимости для "world” [аргумент])

Лев Чашкин wrote:

Обновление не пошло.
!!! Problem resolving dependencies for www-plugins/adobe-flash from `selected
… готово!

!!! The ebuild selected to satisfy “www-plugins/adobe-flash” has unmet requirements.

  • www-plugins/adobe-flash-11.2.202.440::gentoo USE="-debug -kde (-selinux)" CPU_FLAGS_X86="-sse2"

The following REQUIRED_USE flag constraints are unsatisfied:
cpu_flags_x86_sse2

The above constraints are a subset of the following complete expression:
cpu_flags_x86_sse2 debug? ( abi_x86_32 ) any-of ( abi_x86_64 abi_x86_32 )

(требуется по зависимости для “`selected” [комплект])
(требуется по зависимости для “@world” [аргумент])

Добавьте в make.conf

CPU_FLAGS_X86="sse2"

а вообще надо новости читать, там все написано.

Спасибо за рекомендацияю читать новости. Но там больше все для специалистов. До любителей доходит долго. Просто сижу на calculate из за патриотизма а не по необходимости, давно бы ушел на DISTR, где сображать не надо.

Я тоже не специалист, а любитель. Но новости стараюсь читать.