(Решено) Неудачная попытка обновления

Здравствуйте.
При обновлении из мира получил:
The current version of portage supports EAPI ‘4’. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
Что такое EAPI, надо ли его обновлять и как это сделать?

Похоже сначала надо обновить portage а только потом мир
выполните

emerge portage

Почитайте
http://www.gentoo.ru/node/16224
http://www.gentoo-wiki.info/EAPI
http://devmanual.gentoo.org/ebuild-writing/eapi/index.html

Разве eix-sync этого не делает?

Виктор Боголюбов wrote:

Разве eix-sync этого не делает?

Это делает не eix-sync - eix-sync это программа синхронизации дерева портов
в /usr/portage - не путайте с программой sys-apps/portage
которую Вам и надо обновить
По идее должна обновить sys-apps/portage команда emerge -uDN world
Но иногда как я заметил - она сразу не обновляет пакет portage
а иногда как в вашем случае portage обновляются где то в середине или еще где
Я обычно всегда сначала после eix-sync обновляю emerge sys-apps/portage а только потом emerge -uDN world

Почитайте
http://www.gentoo.ru/node/17346
https://www.google.ru/search?q=The+current+version+of+portage+supports+EAPI+‘4’.You+must+upgrade+to+a+newer+version+of+portage+before+EAPI+masked+packages+can+be+installed.&oq=The+current+version+of+portage+supports+EAPI’4’.+You+must+upgrade+to+a+newer+version+of+portage+before+EAPI+masked+packages+can+be+installed.&aqs=chrome.0.57j64&sugexp=chrome,mod=5&sourceid=chrome&ie=UTF-8&qscrl=1

The current version of portage supports EAPI ‘4’. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

кривой перевод

В текущей версии поддерживается Portage EAPI '4 '. Вы должны перейти на
новую версию Portage до EAPI указанную в масках пакетов которые могут быть установлены.

Короче - обновите sys-apps/portage

Большое спасибо. Сделал как Вы советовали и “процесс пошёл…”.

Не за что
Просто совет - читайте внимательней что пишет система - обычно все пишется на понятном английском :slight_smile: