Calculate Forum

Не обновляется сервер!

При обновлении возникает ошибка.

server ~ # emerge -avuDN --autounmask world

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=net-dns/bind-9.6.1_p1[sdb-ldap]" has unmet requirements.
- net-dns/bind-9.8.1_p1::gentoo USE="berkdb ipv6 ldap (multilib) sdb-ldap ssl -caps -dlz -doc -geoip -gost -gssapi -idn -mysql -odbc -pkcs11 -postgres -rpz (-selinux) -threads -urandom -xml" CDISTRO="CDS"

  The following REQUIRED_USE flag constraints are unsatisfied:
    berkdb? ( dlz ) ldap? ( dlz ) sdb-ldap? ( dlz )

  The above constraints are a subset of the following complete expression:
    postgres? ( dlz ) berkdb? ( dlz ) mysql? ( dlz !threads ) odbc? ( dlz ) ldap? ( dlz ) sdb-ldap? ( dlz ) gost? ( ssl ) threads? ( caps )

(dependency required by "sys-apps/calculate-server-2.1.15-r4[-calculate_nonamed]" [installed])
(dependency required by "sys-apps/calculate-install-2.2.27-r4[pxe]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Честно говоря, не понимаю, что нужно сделать, чтобы нормально обновить сервер. Посоветуйте, кто знает.

попробуйте добавить USE-флаг “dlz”

Добавил. Теперь другая ошибка.

...
[blocks b      ] <sys-apps/sysvinit-2.88-r3 ("<sys-apps/sysvinit-2.88-r3" is blocking sys-apps/util-linux-2.20.1-r1)
[ebuild     U  ] app-text/docbook-xsl-stylesheets-1.76.1 [1.75.2] 3,597 kB
[ebuild  N     ] app-text/docbook-xml-dtd-4.2-r2  77 kB
[ebuild     U  ] sys-fs/xfsdump-3.0.6 [3.0.1] 772 kB
[ebuild     U  ] sys-libs/tdb-1.2.9 [1.2.7-r1] USE="-python (-static-libs%) (-tdbtest%) (-tools%)" 360 kB
[ebuild     U  ] sys-libs/talloc-2.0.7 [2.0.1-r2] USE="-compat -python% (-doc%) (-static-libs%) (-swig%)" 363 kB
[blocks B      ] <sys-libs/talloc-2.0.5 ("<sys-libs/talloc-2.0.5" is blocking sys-libs/talloc-2.0.7)

Total: 35 packages (32 upgrades, 1 downgrade, 2 new), Size of downloads: 126,590 kB
Conflict: 2 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/talloc-2.0.7::gentoo, ebuild scheduled for merge) pulled in by
    sys-libs/talloc required by (net-fs/samba-3.5.11::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

eix-sync выполняли перед обновлением? Зачем Вам --autounmask, Вы размаскировывали какие-то пакеты?

Да, конечно, eix-sync выполнял.
–autounmask добавил исходя из документации по calculate
Есть пакеты, которые не являются стабильными в gentoo. Однако они мне необходимы.

Что-то я совсем запутался в том, как обновлять. Почему система обновления не может принять решение какие зависимости нужны к обновлению? Или спросить меня, о необходимости удовлетворения зависимостей и обновления тех или иных пакетов? Как обновить корректно сервер в таком случае?

...
[blocks b      ] <sys-apps/sysvinit-2.88-r3 ("<sys-apps/sysvinit-2.88-r3" is blocking sys-apps/util-linux-2.20.1-r1)
[ebuild     U  ] app-text/docbook-xsl-stylesheets-1.76.1 [1.75.2] 3,597 kB
[ebuild  N     ] app-text/docbook-xml-dtd-4.2-r2  77 kB
[ebuild     U  ] sys-fs/xfsdump-3.0.6 [3.0.1] 772 kB
[ebuild     U  ] sys-libs/tdb-1.2.9 [1.2.7-r1] USE="-python (-static-libs%) (-tdbtest%) (-tools%)" 360 kB
[ebuild     U  ] sys-libs/talloc-2.0.7 [2.0.1-r2] USE="-compat -python% (-doc%) (-static-libs%) (-swig%)" 363 kB
[ebuild     U ~] net-fs/samba-3.6.3 [3.5.11] USE="acl aio client cups ldap netapi pam quota readline server smbclient -addns -ads -avahi -caps -cluster -debug -doc -examples -fam -ldb -smbsharemodes -swat -syslog -winbind (-smbtav2%)" 28,315 kB
[blocks B      ] net-fs/cifs-utils ("net-fs/cifs-utils" is blocking net-fs/samba-3.5.11)
[blocks B      ] <sys-libs/talloc-2.0.5 ("<sys-libs/talloc-2.0.5" is blocking sys-libs/talloc-2.0.7)
[blocks B      ] <net-fs/samba-3.6_rc1 ("<net-fs/samba-3.6_rc1" is blocking net-fs/cifs-utils-5.3)

Total: 36 packages (32 upgrades, 1 downgrade, 3 new), Size of downloads: 154,481 kB
Conflict: 4 blocks (3 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/talloc-2.0.7::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/talloc-2.0.5 required by (net-fs/samba-3.6.3::gentoo, ebuild scheduled for merge)

  (net-fs/cifs-utils-5.3::gentoo, ebuild scheduled for merge) pulled in by
    net-fs/cifs-utils required by (net-fs/samba-3.6.3::gentoo, ebuild scheduled for merge)

sys-libs/talloc-2.0.5 блокирует sys-libs/talloc-2.0.7, с ним вообще веселая история. Попробуйте удалить и поставить новую версию:

emerge -C sys-libs/talloc; emerge -1 sys-libs/talloc

Спасибо огромное! Процесс пошёл! :slight_smile:

Mastodon Mastodon