Ошибка при обновлении

При обноволении через

emerge --update --newuse --deep  @world

Выдает

Calculating dependencies... done!
[binary     U  ] sys-devel/automake-wrapper-5 [4]
[binary     U  ] kde-base/kdepasswd-4.7.4 [4.7.3]
[binary     U  ] kde-base/plasma-apps-4.7.4 [4.7.3]
[binary     U  ] kde-base/keditbookmarks-4.7.4 [4.7.3]
[binary     U  ] kde-base/kdebase-data-4.7.4 [4.7.3]
[binary     U  ] kde-base/kdemultimedia-kioslaves-4.7.4 [4.7.3]
[binary     U  ] kde-base/kstyles-4.7.4 [4.7.3]
[binary     U  ] kde-base/konqueror-4.7.4 [4.7.3]
[binary     U  ] kde-base/dolphin-4.7.4 [4.7.3]
[binary     U  ] kde-base/thumbnailers-4.7.4 [4.7.3]
[binary     U  ] kde-base/mplayerthumbs-4.7.4 [4.7.3]
[binary     U  ] kde-base/kcontrol-4.7.4 [4.7.3]
[binary     U  ] kde-base/kmenuedit-4.7.4 [4.7.3]
[binary     U  ] kde-base/klipper-4.7.4 [4.7.3]
[binary     U  ] kde-base/ksaneplugin-4.7.4 [4.7.3]
[binary     U  ] kde-base/kolourpaint-4.7.4 [4.7.3]
[ebuild   R    ] dev-libs/libxml2-2.7.8-r3  USE="python*" 
[ebuild   R    ] media-libs/lcms-1.19  USE="python*" 
[binary     U  ] kde-base/gwenview-4.7.4 [4.7.3]
[binary     U  ] kde-base/ark-4.7.4 [4.7.3]
[binary     U  ] kde-base/kscd-4.7.4 [4.7.3]
[binary     U  ] kde-base/systemsettings-4.7.4 [4.7.3]
[binary     U  ] kde-base/kdeartwork-styles-4.7.4 [4.7.3]
[binary     U  ] sys-apps/calculate-client-2.2.27 [2.2.26]
[binary     U  ] kde-base/kscreensaver-4.7.4 [4.7.3]
[binary     U  ] kde-base/kdeartwork-kscreensaver-4.7.4 [4.7.3]
[ebuild  N     ] media-libs/sk1libs-0.9.1 
[binary     U  ] kde-base/pykde4-4.7.4 [4.7.3]
[binary     U  ] kde-base/libplasmaclock-4.7.4 [4.7.3]
[binary     U  ] kde-base/kgpg-4.7.4 [4.7.3]
[binary     U  ] kde-base/kuser-4.7.4 [4.7.3]
[binary     U  ] kde-base/kabcclient-4.7.4 [4.7.3]
[binary     U  ] kde-base/system-config-printer-kde-4.7.4 [4.7.3]
[binary     U  ] kde-base/printer-applet-4.7.4 [4.7.3]
[binary     U  ] kde-base/kdm-4.7.4 [4.7.3-r1]
[binary     U  ] kde-base/solid-4.7.4 [4.7.3]
[binary     U  ] kde-base/kdebase-kioslaves-4.7.4 [4.7.3]
[binary     U  ] kde-base/plasma-workspace-4.7.4 [4.7.3-r7]
[binary     U  ] kde-base/ksmserver-4.7.4 [4.7.3]
[binary     U  ] kde-base/powerdevil-4.7.4 [4.7.3]
[binary     U  ] kde-base/kremotecontrol-4.7.4 [4.7.3]
[binary     U  ] kde-base/kinfocenter-4.7.4 [4.7.3]
[binary     U  ] kde-base/krunner-4.7.4 [4.7.3]
[binary     U  ] kde-base/kdeplasma-addons-4.7.4 [4.7.3-r1]
[binary     U  ] sys-apps/calculate-utilities-2.2.27-r1 [2.2.26-r10]
[binary     U  ] kde-base/kdepim-common-libs-4.7.4 [4.7.3]
[binary     U  ] kde-base/kdebase-runtime-meta-4.7.4 [4.7.3]
[binary     U  ] media-video/kdenlive-0.8.2.1 [0.8.2]
[binary     U  ] kde-base/kontact-4.7.4 [4.7.3]
[binary     U  ] kde-base/kdepim-strigi-analyzer-4.7.4 [4.7.3]
[binary     U  ] kde-base/kleopatra-4.7.4 [4.7.3]
[binary     U  ] kde-base/konsolekalendar-4.7.4 [4.7.3]
[binary     U  ] kde-base/kalarm-4.7.4 [4.7.3]
[binary     U  ] kde-base/kdebase-startkde-4.7.4 [4.7.3]
[binary     U  ] kde-base/akonadiconsole-4.7.4 [4.7.3]
[binary     U  ] kde-base/kdepim-kresources-4.7.4 [4.7.3]
[binary     U  ] kde-base/korganizer-4.7.4 [4.7.3]
[binary     U  ] kde-base/kjots-4.7.4 [4.7.3]
[binary     U  ] kde-base/knotes-4.7.4 [4.7.3]
[binary     U  ] kde-base/akregator-4.7.4 [4.7.3]
[binary     U  ] kde-base/kaddressbook-4.7.4 [4.7.3]
[binary     U  ] kde-base/kmail-4.7.4 [4.7.3]

The following USE changes are necessary to proceed:
#required by media-libs/sk1libs-0.9.1, required by media-gfx/uniconvertor-1.1.5, required by media-gfx/inkscape-0.48.2, required by @selected, required by @world (argument)
>=media-libs/lcms-1.19:0 python
#required by app-admin/system-config-printer-common-1.3.6, required by kde-base/printer-applet-4.7.4, required by app-misc/cl-kde-meta-4.7.0-r4[cups], required by app-misc/cld-meta-11.12[-calculate_nokde], required by app-misc/calculate-meta-11.12, required by @selected, required by @world (argument)
>=dev-libs/libxml2-2.7.8-r3 python

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).

Что именно из этих пакетов нужно раз маскировать? Да, я проверил и обнаружил более новые версии уже установленными.

Не размаскировать, а добавить USE флаги.
Установленный Вами inkscape по зависимостям тянет uniconvertor, которому в свою очередь нужен sk1libs, который хочет, чтобы lcms был собран с USE-флагом “python”.

Во втором случае Вы просто не обновили портежи с оверлеем (eix-sync), т.к. libxml2 давно уже собран с флагом “python”.

Спасибо, помогло.

Ошибка схожая, только чуть побольше.
Хотелось бы узнать “толкование” :slight_smile:

The following USE changes are necessary to proceed:
#required by media-libs/mesa-7.11.2, required by kde-base/kwin-4.7.1-r1, required by app-misc/cl-kde-meta-4.7.0-r3, required by app-misc/cld-meta-11.9, required by selected, required byworld (argument)

=dev-libs/libxml2-2.7.8-r3 python

к чему упоминания selected иworld?
Так же по-поводу требуемого USE=python:

  • добавлять именно python или конкретизировать python2, python3
  • лучше добавить USE=python к конкретному пакету или в целом?

Обновите портежи и оверлей eix-sync. Чтобы подобных проблем не было, переведите портежи на гит.