Не стартуют иксы после обновления

Всем привет, в генте я ни в зуб ногой, так что сильно не пинайте. Вот решил попробовать…
Свежеустановленная калька на кедах, сразу принял обновления, перезагрузил и опа…
При загрузке появляется лого и вылет в ошибку.
error: unexpectedli disconnected from boot status daemon
и еще ругался на модемменеджер, но я его похерил и эта ошибка больше не появляется.
если логинюсь в консоли и пытаюсь стартануть иксы, то вижу только стрелку-курсор.

что делать?

Здравствуйте.
наверняка, нужны логи загрузки.
ламерский совет: установить кальку и только потом обновлять читая сообщения.

Hi,
emerge --unmerge plymouth plymouth-kcm plymouth-openrc-plugin (if installed of course). Use LiveCD if login is impossible. Go to /etc/portage/profile and write out these apps as installed. No warranty…

You should be root. Use su in LiveCD or your root password in your installed system (in terminal).

Sorry, I don’t know your experience. Open terminal/konsole in LiveCD and open dolphin as root (su command). Go to the installed system and delete all plymouth apps from /usr/bin. Start your installed system and unmerge these aps. You can use chroot in LiveCd also.

Thank you for help.
I can login as root or user
I uninstalled Plymouth, but unfortunately it did not help.

Write startx in terminal after login. Can you start sddm from terminal after login as root? Sddm can login you as root after change in sddm.conf. Check sddm. conf in /etc. It is my sddm.conf:
[General]
InputMethod=ibus
InputMethod=qtvirtualkeyboard
Numlock=none

[Theme]
CursorTheme=Calculate
DisableAvatarsThreshold=7
EnableAvatars=true
FacesDir=/usr/share/sddm/faces
ThemeDir=/usr/share/sddm/themes

[Users]
DefaultPath=/usr/local/bin:/usr/bin:/bin
HideShells=
HideUsers=
RememberLastSession=true
RememberLastUser=true
ReuseSession=false

[Wayland]
EnableHiDPI=false
SessionCommand=/usr/share/sddm/scripts/wayland-session
SessionDir=/usr/share/wayland-sessions
SessionLogFile=.local/share/sddm/wayland-session.log

[X11]
DisplayCommand=/usr/share/sddm/scripts/Xsetup
DisplayStopCommand=/usr/share/sddm/scripts/Xstop
EnableHiDPI=false
MinimumVT=1
ServerArguments=-nolisten tcp
ServerPath=/usr/bin/X
SessionCommand=/usr/share/sddm/scripts/Xsession
SessionDir=/usr/share/xsessions
SessionLogFile=.local/share/sddm/xorg-session.log
UserAuthFile=.Xauthority
XauthPath=/usr/bin/xauth
XephyrPath=/usr/bin/Xephyr

Maybe some trivial problem? Check your function keys setting: ctrl+alt F!, F2 and so on.

What is your GPU? Have you good drivers installed?

All logs are stored in /var/log. I have OpenRC installed as a init, you systemd probably, so try journalctl in terminal as root…

Thanks for your help.
I reinstalled OS.
I try to update the system again
If there are problems, I’ll let you know
Thanks

pardon me if i get it wrong but calculate-linux doesn’t use systemd by default

cl-setup-video --video list
выбрать свое видео cl-setup-video --video свое видео
dispatch-conf && reboot

все от рута, ясен динозавр.
пысы == и да, плимут обратно поставь. а то насоветуют тут…

Всем спасибо,
переставил систему, обновился, полет нормальный.
Видимо в первый раз обновление прошло не успешно.
Продолжаю обустраивать под себя кальку)))

1 Like