Calculate Forum

Как установить более старую версию пакета, отсутствующую в репозиториях?

Устанавливается такая

[I] net-vpn/networkmanager-l2tp
Доступные версии: ~1.8.0 1.8.2{tbz2} {gnome static-libs}
Установленные версии: 1.8.2{tbz2}(05:51:05 12.03.2021)(gnome -static-libs)
Домашняя страница: https://github.com/nm-l2tp/network-manager-l2tp
Описание: NetworkManager L2TP plugin

А нужна старая

network-manager-l2tp_1.2.16-1_amd64

Нужна, потому что на старой поднимается l2tp подключение, а на новой нет ((

Если коротко - создать локальный оверлей, скопировать туда ebuild от новой версии, отредактировать, установить.
Но возможно будет проще разобраться, почему нет подключения на новой версии.

ну там целая история с этим - во-первых, почти всегда l2tp не подключается, но иногда - подключается, по какой причине - непонятно )) Во-вторых, после отключения l2tp ломаются маршруты и нужно заново подключаться к локалке, чтобы заработал инет )) Поэтому, мне проще когда нужно заюзать l2tp - загрузиться с дистра где с этим проблем нет, а потом обратно в кальку. Хотя заметил, что на других дистрах производительность примерно такая же как в кальке на этом железе

© 2007-2020 Calculate Ltd.
Mastodon Mastodon