Calculate Forum

Кто нибудь может объяснить, зачем в систему устанавливается вот этот пакет?

Кто нибудь может объяснить, зачем в систему устанавливается вот этот пакет

Библиотека для доступа к системе электронного правительства Чехии “Datove schranky” (N) net-libs/dslib-3.0-r4 (84 KiB)

и почему его нельзя замаскировать?
Маскировка ничего не даёт, emerge всё равно его устанавливает.
Этот пакет выдаёт ошибку при установке и весь процесс обновления останавливается. Посоветуйте, как его прибить навсегда!

Оказывается он нужен пакету calculate-utils
Нафига утилитам линукса доступ к системе электронного правительства Чехии? :slight_smile:
Значит есть пакеты, которые я не могу замаскировать?

dslib прописан в
/var/db/repos/calculate/profiles/default/package.unmask
Зачем - тоже не знаю

Это уже обсуждалось тут

Насчёт мусора согласен! Но тут, из-за этого мусора, не устанавливается пакет утилит, которые, собственно, и делают генту калькулейтом. Это более странно, чем просто установка сторонней библиотеки, которую можно выпилить. Я, конечно, понимаю, что в этой библиотеке есть какая-то функция, которую используют утилиты. Но, что это за редкая функция такая, что её нельзя взять из других стандартных библиотек или перенести в утилиты из этой библиотеки?

© 2007-2020 Calculate Ltd.
Mastodon Mastodon