Stuck during Installation on existing partitions using the latest ISO (17.12)

impossible to install on existing partitions using the latest ISO.
I have a previously installed calculate version on it (2 versions ago), it does not boot so I decided to reinstall (I made some unsafe tests).

During the installation, I was stuck at the “installation type” tab.
in “installation type” I chose “use current partitions”
it said “autopartition options are not available in manual partition”.

@phoenix83 helped me in the IRC: I just had to select the “blank” option in the partition table select control.
( if your using manual partition you need to change partition type from dos or gpt to blank)
This worked.

next: in layout tab
it says “please specify EFI partition by UEFI option”
I manually set/dev/nvme0n1p1 to be mounted in /boot/efi with uefi fs type - no formatting !
(In fact I used my previous fstab for that)
No luck.
I can’t see where that “UEFI option” is.

More details:

this is my HD layout:

Device             Start       End   Sectors   Size Type
 /dev/nvme0n1p1      2048    534527    532480   260M EFI System
 /dev/nvme0n1p2    534528    567295     32768    16M Microsoft reserved
 /dev/nvme0n1p3    567296 332257279 331689984 158.2G Microsoft basic data
 /dev/nvme0n1p4 498100224 500107263   2007040   980M Windows recovery environment
 /dev/nvme0n1p5 332257280 365025279  32768000  15.6G Linux swap
/dev/nvme0n1p6 365025280 498100223 133074944  63.5G Linux filesystem

I want to set nvme0n1p5 as swap and nvme0n1p6 as root
but impossible to select the existing EFI part in /boot/efi. and I got this message.

I took a screenshot of both problems (first: just for the record.

here is the fstab of the previously installed calculate system:

 # / was on /dev/nvme0n1p6 during installation
UUID=3b481b7f-3636-4f68-a3d3-38c49b6a5624   /   ext4    noatime,discard 0 1

 # /boot/efi was on /dev/nvme0n1p1 during installation
UUID=E0B5-E7CE  /boot/efi   vfat    noatime,discard 0 0

 # /home was on /dev/sda1 during installation
UUID=85c50a6a-024f-40f6-a0b3-b2149e2fc734   /home   ext4    noatime 0 0

 # swap was on /dev/nvme0n1p5 during installation
UUID=389475bc-028b-44d3-bee3-d4d6c8b0483d   none    swap    sw  0 0

proc        /proc       proc    defaults        0 0
shm     /dev/shm    tmpfs   nodev,nosuid,noexec 0 0

Note: the comments on the images are inverted.


i found this

An EFI System partition is distinguished by its GUID type C12A7328-F81F-11D2-BA4B-00A0C93EC93B, not by a boot flag. Yes, this partition needs to be formatted FAT32. Not all FAT32 partitions are EFI System partitions, only one of them, and that one, if present, is small and has a special purpose. On a computer which boots through BIOS or BIOS emulation you don’t need it. You may want to create an EFI System partition (about 300 MB, in parted say mkpart fat32 and set boot on), for the case that some day the disk will be moved to a computer with UEFI.

this could be your problem just a thought tho, if you havent already you might want to use gparted and set a boot flag on the boot partition. this is done by right click the partition and select set flag option then select boot from the list.

I can try.
I’ll do that tomorrow.

Thanks !

the boot & esp flags where already there ;-(

there are 2 flags set:boot & esp on this partition.

Weird, I can’t reinstall using the installer.

I am trying to get the ISO from the version of calculate of July, impossible to recover it from the web.

For the record, to install on existing partitions during the install:

  • at “installation type” tab, select “blank” for partition table (no option)

  • click nothing else there

  • at “layout” tab, add the partitions you want, but not the EFI that is supposed to be /boot

  • instead at the bottom “advanced”, select in “UEFI boot” and set to the boot HDD (where the EFI partition exists)

this allowed me to finish the setup