[Solved]X Server doesn't work.

Using XFCE iso 17.12.2

Calculate Linux works when booted from the Live DVD (on Flash Drive).

I tried installing it. It seems to install OK but the X Server does not work. I just get a blank screen.

Ctrl-Alt-F1 lets me log into a console so the keyboard works.

If I change the name of the /etc/X11/xorg.conf so the X Server cannot use it, the gui login screen comes up so I know the X Server works but the mouse and keyboard don’t work. Ctrl-Alt-F1 does nothing. Both are USB. It is using the nouveau video driver.

Here are the error lines in the Xorg log:

grep ‘EE’ Xorg.0.log
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 17.850] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
[ 17.850] (EE) No devices detected.
[ 17.850] (EE)
[ 17.850] (EE) no screens found(EE)
[ 17.850] (EE)
[ 17.850] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 17.850] (EE)
[ 17.851] (EE) Server terminated with error (1). Closing log file.

The whole file is attached.

It has been a really long time since I had to configure the X Server manually and I don’t remember what to do next.

Xorg.0.log (5.05 KB)

what is your graphic card ?

graphics -> Nvidia GeForce 9600GT (PCI-E 2.0)

If your system always installed, can you log in in the console and say me the version of nvidia-drivers ?

eix nvidia-drivers

eix only lists nvidia-drivers that are available, none are installed.

You can see from the X-log it is using the nouveau driver:

[ 17.738] (II) LoadModule: “nouveau”
[ 17.738] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[ 17.768] (II) Module nouveau: vendor=“X.Org Foundation”
[ 17.768] compiled for 1.19.5, module version = 1.0.15
[ 17.768] Module class: X.Org Video Driver
[ 17.768] ABI class: X.Org Video Driver, version 23.0
[ 17.768] (II) NOUVEAU driver
[ 17.768] (II) NOUVEAU driver for NVIDIA chipset families :
[ 17.768] RIVA TNT (NV04)
[ 17.768] RIVA TNT2 (NV05)
[ 17.768] GeForce 256 (NV10)
[ 17.768] GeForce 2 (NV11, NV15)
[ 17.768] GeForce 4MX (NV17, NV18)
[ 17.768] GeForce 3 (NV20)
[ 17.768] GeForce 4Ti (NV25, NV28)
[ 17.768] GeForce FX (NV3x)
[ 17.768] GeForce 6 (NV4x)
[ 17.768] GeForce 7 (G7x)
[ 17.768] GeForce 8 (G8x)
[ 17.768] GeForce GTX 200 (NVA0)
[ 17.768] GeForce GTX 400 (NVC0)

I think the nouveau drivers doesn’t work fine with your card.

Try to install nvidia drivers

emerge nvidia-drivers

And enable them :

cl-setup-video --video nvidia

and try to reboot

The problem was not the nouveau driver.

I switched from XFCE to KDE to see if that resolved the problem, it did not.

I got a hint from the Xlog file:

[ 17.505] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.

I renamed the xorg.conf file and created my own with only the following in it:

Section “ServerFlags”

Option “AutoAddDevices” “false”


I rebooted and the KDE login screen came up, I logged in and the mouse and keyboard worked. Everything looked good until I realized my ethernet adapter had not been detected!

Now it looks like udev is messed up?

There was another problem I was having that I did not mention before because I did not think it was related but it turned out to be the key to resolving this problem.

After installing calculate, when booting, the old Slackware (lilo) splash screen would show. I pressed return and calculate Linux would boot with the problems previously mentioned.

I had been trying to use the partitions that were already on the disk but I must have screwed something up. I decided to let calculate partition the disk itself. I told it to use a GPT partition table and uefi boot method. That solved the problems I was having with the X server and now udev was detecting my hardware.

The only problem that remained with that partition option was it won’t let me mount my 2nd disk on /home. I can do that manually but the guest user it created won’t be in my /home directory and it is supposed to migrate my old users to calculate which it cannot do if my 2nd disk is not mounted on /home.

Next, I tried to use the partition recommendations in the Gentoo Handbook and assign them manually in the installer so I can mount my 2nd disk on /home. The installer won’t accept the uefi partition I created. It keeps telling me to use the uefi option, which I did, but it does not accept it so I let it boot using the bios.

That works. It did not migrate my users but I only half expected that to work. It probably works when you upgrade calculate Linux.

Cool :slight_smile:
Several persons have problems with XFCE flavour.
I never reproduced these problems, but, i always tested in a virtual machine.
It looks like XFCE is haunted!