[SOLVED] Wine stopped working

When I first installed Calculate two weeks ago I was delighted that everything worked including my only wine program, Photoshop CS6. Worked great in Playonlinux/Wine combo.
After couple of CL Updates Wine stopped working.
Tried clean install of CL with latest iso, and wine does not work.
Is this a known issue? I could not find any fresh issues or answers on the net.


So this is what I did to confirm the issue. Installed CL using cldc-20171025-x86_64.iso
I did not want to update right after installation, I only did

cl-update --sync-only, followed by eix-sync

Now I installed Playonlinux. Installed Photoshop CS6 and it ran as it always did on my other Linux partition with Manjaro OpenRC. No problem, all works! Great!

Now I ran cl-update and after installing all the updates, shown in attached pic, Wine no longer works.
Any clues please? Thank you.


No one has any suggestion/idea/comment?
I can’t be the only one using wine in CL? Anyone having this problem after update and with latest iso?

Playonlinux debugger gives me this error:

err:shell:HCR_GetFolderAttributes should be called for simple PIDL’s only!

Please anyone help!

Installing wine 2.20-staging within Playonlinux solved the issue. Whew!

or install app-emulation/wine-vanilla

Thank you , will try.
Good to have more options :slight_smile:

I am having the same problems. I have installed app-emulation/wine-vanilla. Did all the updates. Now playonlinux gives me a black screen on starting games. I spent a day trying to figure this out. No clues! Also, I have bumblebee installed. Bumblebee works fine with glxgears on my desktop but it doesn’t seem to be providing the same results on playonlinux games. Any ideas folks?

Hi again,
Another problem maybe is: I tried to install sys-firmware/alsa-firmware and I get: Conflict: 2 blocks (2 unsatisfied): sys-kernel/linux-firmware-20170906 sys-kernel/calculate-sources-4.9.51… Why would these kernel be conflicting with alsa-firmware? Also, my playonlinux problem is NOT solved… Forgot the remove before posting.