[solved] Virtualbox failed to acquire Virtualbox COM object

Hi there,

I just installed yesterday virtualbox as recommended

"emerge -avq app-emulation/virtualbox app-emulation/virtualbox-extpack-oracle app-emulation/virtualbox-modules app-emulation/virtualbox-additions

and it worked fine.

After an update i now get the error message from the topic. I tried to reinstall VirtualBox without installing first but it didn’t work.

Anybody have an idea how to fix this?



P.S. complete uninstall and re-install didn’t do it neither.

Hi Dirk,
What the kernel version are you use?

Sorry for the late reply

Linux calculate 4.9.67-calculate #1 SMP PREEMPT Tue Dec 5 12:10:57 UTC 2017 x86_64 Intel® Core™ i7-7700HQ CPU @ 2.80GHz GenuineIntel GNU/Linux

If i run it in a terminal (just downgraded to Version 5.1.26

dirk@calculate ~ $ virtualbox
VirtualBox: Error -610 in supR3HardenedMainInitRuntime!
VirtualBox: dlopen("/usr/lib64/virtualbox/VBoxRT.so",) failed:

VirtualBox: Tip! It may help to reinstall VirtualBox.

An update to version 5.2.2 is being prepared. It will be possible to try it.

Could you let me know when i can try it?



Sorry, there was a delay due to server problems. Today there will be an update.

Did a fully uninstall, rebooted and re-installed with no success.

Any idea?

The only way to run it is at the moment as root and I applied these commands in order to get it started as root:

sudo chown root:root /usr
sudo chown root:root /usr/lib
sudo chown root:root /usr/lib/virtualbox

So, for now i can use it but running it as root.

Does this provide enough inside to see what went wrong with my virtual-box?



“An update to version 5.2.2 is being prepared. It will be possible to try it.”

I had no issues running virtualbox, but after today’s update to 5.2.2. guest machine (Windows 7) will not run in seamless mode.

Mine seems to work fine as root, but that is not how i want to use my Virtual-Box, i want to use it as normal user though.

You have to be member of vboxusers group.

I am and I still get the COM error :frowning:

I just made a YouTube Video, the final fix.


First I made a YouTube video called workaround, that could still help in case the fix wouldn’t work at all times.