[Solved] Samba will not reliably see my Windows Network

This is a Gentoo Only issue on my Network.
I never had experienced an issue such as this and have been using Samba since 1999.
SPecs: Small Peer to Peer Network.
…4 WinXP desktops each with 1 folder shared Read Write
… Thinkpad Linux machine connects by Hardwire Cat5
…Thinkpad Xfce4 has installed Debian Wheezy/Sid, Slackware 13.37, Arch, Calculate Gentoo.
…All installs when booted Immediately see and access the WinXP shares EXCEPT Calculate.
Calculate can Display it’s own Shared Directories which WinXP can use but Not Easily see the WinXP Shares.
…The WinXP WorkGroup folder does not Appear when Browsing from Thunar file Manager.
…Debian, Arch & Slackware w/ Xfce4 do all display the WorkGroup and shares in Thunar.

IF I process these commands multiple times
_smbpasswd -e sqlpython
/etc/init.d/samba restart_

Then Perhaps in about 10 to 15 minutes I can See the WinXp Shares

Here is my working smb.conf Dump
Any suggestions as to Why the slowness of Calculate recognizing WinXp and Or WinXP to recognize Calcultate
…would be appreciated…

workgroup = MYGROUP
server string = %h server (Calculate)
interfaces =, eth0, wlan0, eth1
bind interfaces only = Yes
map to guest = Bad User
obey pam restrictions = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = Enter\snew\s\spassword:* %n\n Retype\snew\s\spassword:* %n\n password\supdated\ssuccessfully .
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
printcap name = cups
dns proxy = No
usershare allow guests = Yes
usershare max shares = 100
panic action = /usr/share/samba/panic-action %d
idmap config * : backend = tdb

comment = Home Directories
valid users = %S
create mask = 0775
directory mask = 0775

comment = All Printers
path = /var/spool/samba
create mask = 0700
printable = Yes
print ok = Yes
browseable = No

comment = Printer Drivers
path = /var/lib/samba/printers

path = /home/sqlpython/Public
valid users = sqlpython
create mask = 0775

path = /home/sqlpython/SharedDocs
valid users = sqlpython
create mask = 0775

Seems I have reached a workable compromise between Samba and my Network.
The shares from the WinXP machines now come quickly and connect.
My Laptop shares in turn are quickly recognized and accessible with password by the WinXP machines…
In the past as this is a small closed network I have always set

Security = share
together with

_interfaces =, eth0, wlan0, eth1
bind interfaces only = Yes
valid users = %S_

as some weak security
However this time with Calculate I had set

Securtiy = user

Seems that setting with the

interface =
bind to interfaces only = yes

Makes for a Wrestling match to determine user control of shares
Eventually the shares show but it takes Minutes
Somewhat like a Sever Election process

**** Solution that worked for my was to make the following lines inactive
when using Security = user ###

_;interfaces =, eth0, wlan0, eth1
;bind interfaces only = Yes
;valid users = %S_

Turning the above three lines off and on in my Network has validated the
solution over and over