Calculate Forum

[SOLVED] Problem with Nvidia drivers and mesa

There are problems with mesa and the Nvidia proprietary video drivers. After switching to the Nvidia proprietary video drivers, when I tried to install or update, I get this error

!!! The ebuild selected to satisfy “>=media-libs/mesa-9.1.6[egl,X(+),abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_s390_32(-)?,abi_s390_64(-)?]” has unmet requirements.

  • media-libs/mesa-21.1.7::gentoo USE=“X classic d3d9 dri3 egl gallium gbm gles2 llvm lm-sensors opencl vaapi vdpau vulkan wayland xa xvmc zstd -debug -gles1 -osmesa (-selinux) -test -unwind -valgrind -vulkan-overlay -zink” ABI_X86=“32 (64) (-x32)” VIDEO_CARDS="(-freedreno) -i915 -i965 -intel -iris (-lima) -nouveau (-panfrost) -r100 -r200 -r300 -r600 -radeon -radeonsi (-v3d) (-vc4) -virgl (-vivante) -vmware"

The following REQUIRED_USE flag constraints are unsatisfied:
d3d9? ( any-of ( video_cards_iris video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )

I found the simplest way to fix this is remove the d3d9 flag.

Like this:

Add media-libs/mesa -d3d9 to
/etc/portage/package.use

emerge -uD --newuse @world
emerge -av --depclean

Since doing that, there have been no problems (yet).

© 2007-2020 Calculate Ltd.
Mastodon Mastodon