[Solved] Problem Installing Eric IDE

I have been installing either the Eric or Spyder IDE for python for many years.
Never had an issue before as they install rather easily and generically in Debian, Slackware, Arch, Sabayon, Red Hat and Ubuntu linuxes.
Using Emerge with Calculate though I am running into some Unmask issues. I have read some docs but need som help here, Please.
Here is the output As I have tried emerge with and without --autounmask-write

sqlpython # emerge eric --autounmask-write eric

Local copy of remote index is up-to-date and will be used.
Calculating dependencies… done!
[binary U ] dev-python/sip-4.14.2 [4.13.3]
[ebuild N ] dev-python/chardet-2.0.1
[ebuild NS #] dev-lang/python-3.3.0-r1 [2.7.3-r2] USE=“gdbm ipv6 ncurses readline ssl threads xml -build -doc -examples -sqlite -tk -wininst”
[ebuild U ] dev-python/PyQt4-4.9.5 [4.9.4] USE=“assistant*”
[ebuild N ] dev-python/pygments-1.5 USE="-doc {-test}"
[ebuild N ] dev-python/coverage-3.5.3
[ebuild N ] dev-python/pyenchant-1.6.5
[ebuild N ] dev-util/eric-5.2.5 USE=“spell” LINGUAS=“de en es fr it ru -cs -tr -zh_CN”

The following keyword changes are necessary to proceed:
#required by app-portage/gentoolkit-dev-0.2.8, required by app-misc/cl-tools-meta-12.0-r1, required by app-misc/cld-meta-12.0, required by app-misc/calculate-meta-12.0.3, required by selected, required byworld (argument)
=dev-lang/python-3.3.0-r1 ****

The following mask changes are necessary to proceed:
#required by app-portage/gentoolkit-dev-0.2.8, required by app-misc/cl-tools-meta-12.0-r1, required by app-misc/cld-meta-12.0, required by app-misc/calculate-meta-12.0.3, required by selected, required byworld (argument)
# /var/lib/layman/calculate/profiles/calculate/package.mask:

The following USE changes are necessary to proceed:
#required by dev-util/eric-5.2.5, required by eric (argument)
=dev-python/PyQt4-4.9.5 assistant

NOTE: The --autounmask-keep-masks option will prevent emerge
from creating package.unmask or **** keyword changes.

Autounmask changes successfully written. Remember to run dispatch-conf.

!!! The following installed packages are masked:

  • net-misc/cnetworkmanager-0.21.1::gentoo (masked by: package.mask)
    # Pacho Ramos pacho@gentoo.org (24 Nov 2012)
    # Upstream dead for more than 2 years and replaced by nmcli
    # (from NetworkManager) (#339664). Removal in a month.

  • net-wireless/linux-wlan-ng-firmware-0.2.2::gentoo (masked by: package.mask)
    # Pacho Ramos pacho@gentoo.org (24 Nov 2012)
    # Doesn’t build against recent kernels (#247898), all its supported
    # devices are not supported by latest kernels. Removal in a month.
    # See http://wiki.debian.org/linux-wlan-ng for replacements.

You all understand correctly:

emerge eric --autounmask-write



agree, pressing “u”


emerge eric

Let me add now that I have done an autounmask Keep
Should I now put the unmask option back as it was or will it Not be Automatic?

NOTE: The --autounmask-keep-masks option will prevent emerge
from creating package.unmask or **** keyword changes.

Autounmask changes successfully written. Remember to run dispatch-conf.

Portage does not change anything without your knowledge. Therefore, the changes need to be confirmed.

Thank You Very Much…
So as I now understand…
Future packages will NOT be automatically Unmasked.
…And Whenever I DO need to Unmask another package I would follow the same steps.
And no other packages will be Unmasked w/o my specific Request to do so…
K…Correct ?

Great Distro. Great Care has been taken here.
As some Sabayon Packages are Generically Compiled and then available they will install more quickly. However Compiling each in Calculate to my particular install DOES make a noticeable performance Difference… Nice ;^)

Last question as my Eric emerge failed…
Here is the fail and the log.
Some direction would be appreciated.
Thank You

>>> Failed to emerge dev-util/eric-5.2.5, Log file:

>>>  '/var/calculate/tmp/portage/dev-util/eric-5.2.5/temp/build.log'

* Package:    dev-util/eric-5.2.5
 * Repository: gentoo
 * Maintainer: qt@gentoo.org python@gentoo.org
 * USE:        cdistro_CLD cdistro_desktop elibc_glibc kernel_linux linguas_de linguas_en linguas_es linguas_fr linguas_it linguas_ru spell userland_GNU x86
 * FEATURES:   preserve-libs sandbox
 * ERROR: dev-util/eric-5.2.5 failed (setup phase):
 *   USE_PYTHON variable does not enable any Python ABI supported by dev-util/eric-5.2.5
 * Call stack:
 *       ebuild.sh, line  93:  Called pkg_setup
 *       ebuild.sh, line 326:  Called python_pkg_setup
 *   python.eclass, line 427:  Called _python_calculate_PYTHON_ABIS
 *   python.eclass, line 785:  Called die
 * The specific snippet of code:
 *                              die "USE_PYTHON variable does not enable any Python ABI supported by ${CATEGORY}/${PF}"
 * If you need support, post the output of `emerge --info '=dev-util/eric-5.2.5'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/eric-5.2.5'`.
 * The complete build log is located at '/var/calculate/tmp/portage/dev-util/eric-5.2.5/temp/build.log'.
 * The ebuild environment file is located at '/var/calculate/tmp/portage/dev-util/eric-5.2.5/temp/die.env'.
 * Working directory: '/var/calculate/tmp/portage/dev-util/eric-5.2.5'
 * S: '/var/calculate/tmp/portage/dev-util/eric-5.2.5/work/eric5-5.2.5'

****************** and emerge Info ***********************************
Portage 2.2.0_alpha148 (!../var/lib/layman/calculate/profiles/calculate/desktop/CLD/x86/binary, gcc-4.5.3, glibc-2.15-r2, 3.5.3-calculate i686)
                        System Settings
System uname: Linux-3.5.3-calculate-i686-Intel-R-_Core-TM-2_Duo_CPU_T5870_@_2.00GHz-with-gentoo-12.0.3
Timestamp of tree: Sat, 15 Dec 2012 18:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.3.0-r1
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo calculate
Installed sets: @custom
CFLAGS="-O2 -march=i686 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
EMERGE_DEFAULT_OPTS="--binpkg-respect-use=y --quiet-build=n"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles getbinpkg merge-sync metadata-transfer parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow X a52 aac aalib acl acpi alsa amr audiofile avi bash-completion berkdb bittorrent bluetooth bzip2 cairo cdda cddb cdparanoia cdr chm clamav cli consolekit cpudetection cracklib crypt css cue cups cxx dbus djvu dri dv dvd dvdr dvdread ebook encode exif faac fbcon fdftk ffmpeg flac flash foomaticdb fortran ftp gd gdbm ggi gif gphoto2 gpm gtk iconv id3tag ieee1394 imagemagick ipod ipv6 irc jabber jingle jpeg jpeg2k kde libcaca libnotify libwww lirc logrotate lzo mad matroska mbox mikmod mmx mmxext mng modules mp3 mpeg mplayer mudflap musepack nas ncurses networkmanager nfs nls nptl nsplugin ogg oggvorbis openal opencore-amr openexr opengl openmp oscar pam pcre pdf png policykit portaudio ppp pppd qt3support qt4 quicktime raw rdesktop readline samba scanner sdl semantic-desktop session smp speex spell srt sse sse2 sse3 sse4.1 sse4.2 sse4a sse5 ssl ssse3 svg tcpd tga theora tiff truetype unicode usb userlocales v4l v4l2 vaapi vcd vdpau vhosts vidix vorbis wavpack webkit wimax win32codecs wmf wxwindows x264 x86 xanim xcomposite xinerama xpm xv xvid xvmc yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALCULATE="printer wireless" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="* ptp2" CDISTRO="CLD desktop" CL="builder client desktop console consolegui" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" FOO2ZJS_DEVICES="*" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev mutouch synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en bg de es fr it pl pt pt_BR ro ru ru_RU uk" LIRC_DEVICES="devinput" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" RUBY_TARGETS="ruby18 ruby19" THEMES="CLD" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware nouveau nvidia i915 i965 r100 r200 r300 r600 radeonhd dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Lastly, following the method (Success)

emerge spyder --autounmask-write
emerge spyder

Meanwhile I am able to at least install the Python Spyder IDE successfully.
I can use this for Python PyQt development as well but the Eric is more Powerful.

If you see how I can correct my Eric emerge I would be grateful.
Never had to approach configuring the Python environment for an IDE until After the IDE was installed. There by I would use the IDE preference Tools to config.
So, I am a bit lost doing these configs at System level.
I am sure once I see how I will be able to correct the situation.

When you get some free time. I realize that this is a Seldom asked question and you have many more Important Distro development items to attend to first.

Thanks again

Your problem isn’t eric, your problem - python!
You need python 3 to use eric 5 and you need eric 5 to use python 3.
Pay attention to USE_PYTHON and PYTHON_TARGETS.
By default python 3 is not installed in Calculate 13.
If you want to use python 2, install eric 4 :

emerge  "=dev-util/eric-4.5.6"

Sorry, I didn’t notice your reply sooner…

Thank You
I didn’t read more carefully as to what I was installing.
You are of course perfectly correct.
I have been Using Eric 4 all along in all my distros.
For now I am sticking with python 2.7…
I will emerge per your instructions.