[Solved] Portage - can be - A pain in the A$$

I need some How To advise here if the readers here can trudge through my bit of a rant as well as observations.
Basically, I am looking for ideas as to perhaps a method to handle emerge -uDN world more easily.
Thank You for your support.

While Portage is powerful and able to be Finely controlled it can be a lot of busy work.
As one who has used Sabayon-Gentoo for years also, I begin to appreciate how much behind the scenes work the Sabayon Package Manager system does for the user.
I also appreciate the Power and Control of Portage.

For the firs time since I installed CLDX 13 ( about 2 months ago ) I decided to upgrade the tree.
Turns out when I ran
emerge --oneshot portage
emerge -uDNa world
I found that I had 72 packages that could be UPgraded to higer versions.
A few packages including Thunderbird-mail-client were important to me.
So I decided to UPgrade through a

emerge -uDN world

I did have to add a USE= before I continued and did []{.Yuri .to .again .You .Thank .A}

When all was done I had a files to exam for version and configurations to be chosen or eliminated.
A put tkdiff to use to compare New to Old in the /etc dir which I understand is (by default) protected against immediate file modification during the Update. A Very Good Feature.
Seems I managed to make it all through with much time and effort.
However, I had to make quit a few Notes and keeps some instructions as a later Follow Up.

For Example having to remember
_!! existing preserved libs:

package: sys-fs/udev-197-r3
* - /lib64/libudev.so.0
* - /lib64/libudev.so.0.11.5
* used by /usr/lib64/gio/modules/libgvfsdbus.so (gnome-base/gvfs-1.12.3)
* used by /usr/lib64/libatasmart.so.4.0.5 (dev-libs/libatasmart-0.19)
* used by /usr/lib64/libva-dummy.so.1.3200.0 (x11-libs/libva-1.0.15)
* used by 4 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries_

Here are my Instructions after my emerge world

  * System configuring for calculate-utilities package by Calculate Utilities
 * Configuring dependencies: sys-apps/calculate-update
 * Configuring dependencies: app-portage/eix
 * Calculate Utilities have changed files:
 *      /etc/calculate/calculate2.env
 *      /etc/calculate/calculate3.env
 *      /etc/eix-sync.conf
 *      /usr/bin/eix-checkout

 * Messages for package net-mail/mailbase-1.1:

 * Your //var/spool/mail/ directory permissions differ from
 *   those which mailbase wants to set it to (03775).
 *   If you did not change them on purpose, consider running:
 *     chown root:mail //var/spool/mail/
 *     chmod 03775 //var/spool/mail/

 * Messages for package sys-fs/udev-197-r3:

 * Upstream has removed the persistent-cd rules
 * generator. If you need persistent names for these devices,
 * place udev rules for them in /etc/udev/rules.d.
 * udev-197 and newer introduces a new method of naming network
 * interfaces. The new names are a very significant change, so
 * they are disabled by default on live systems.
 * Please see the contents of /etc/udev/rules.d/80-net-name-slot.rules for more
 * information on this feature.
 * You still have /etc/udev/rules.d/70-persistent-net.rules in place from previous udev release.
 * Upstream has removed the possibility of renaming to existing
 * network interfaces. For example, it's not possible to assign based
 * on MAC address to existing interface eth0.
 * See http://bugs.gentoo.org/453494 for more information.
 * Rename your file to something else starting with 70- to silence
 * this warning.
 * You need to restart udev as soon as possible to make the upgrade go
 * into effect.
 * The method you use to do this depends on your init system.
 * For more information on udev on Gentoo, writing udev rules, and
 *          fixing known issues visit:
 *          http://www.gentoo.org/doc/en/udev-guide.xml

 * Messages for package sys-fs/lvm2-2.02.97-r1:

 * lvm volumes are no longer automatically created for
 * baselayout-2 users. If you are using baselayout-2, be sure to
 * run: # rc-update add lvm boot
 * Do NOT add it if you are still using baselayout-1.

 * Messages for package sys-devel/gcc-4.6.3:

 * LTO support is still experimental and unstable.
 * Any bugs resulting from the use of LTO will not be fixed.
 * If you have issues with packages unable to locate libstdc++.la,
 * then try running 'fix_libtool_files.sh' on the old gcc versions.
 * You might want to review the GCC upgrade guide when moving between
 * major versions (like 4.2 to 4.3):
 * http://www.gentoo.org/doc/en/gcc-upgrading.xml

 * Messages for package media-libs/mesa-9.0.1:

 * USE="bindist" was not set. Potentially patent encumbered code was
 * enabled. Please see patents.txt for an explanation.
 * Note that in order to have full S3TC support, it is necessary to install
 * media-libs/libtxc_dxtn as well. This may be necessary to get nice
 * textures in some apps, and some others even require this to run.

 * Messages for package x11-base/xorg-server-1.13.1:

 * virtual/udev was built without keymap support. This may cause input device
 * autoconfiguration to fail.

 * Messages for package app-text/poppler-0.20.5:

 * After upgrading app-text/poppler you may need to reinstall packages
 * linking to it. If you're not a portage-2.2_rc user, you're advised
 * to run revdep-rebuild

 * Messages for package dev-vcs/git-

 * These additional scripts need some dependencies:
 *   git-quiltimport  : dev-util/quilt
 *   git-instaweb     : || ( www-servers/lighttpd www-servers/apache )

 * Messages for package mail-client/thunderbird-17.0.2:

 * You are enabling official branding. You may not redistribute this build
 * to any users on your network or the internet. Doing so puts yourself into
 * a legal problem with Mozilla Foundation
 * You can disable it by emerging thunderbird _with_ the bindist USE-flag
 * If you are experience problems with plugins please issue the
 * following command : rm ${HOME}/.thunderbird/*/extensions.sqlite ,
 * then restart thunderbird

 * Messages for package app-misc/mc-4.8.7:

 * To enable exiting to latest working directory,
 * put this into your ~/.bashrc:
 * . /usr/libexec/mc/mc.sh

 * Messages for package net-wireless/bluez-4.101-r5:

 * If you want to use rfcomm as a normal user, you need to add the user
 * to the uucp group.
 * You will need to add bluetooth service to default runlevel
 * for getting your devices detected. For that please run:
 * 'rc-update add bluetooth default'

 * Messages for package app-admin/sudo-1.8.6_p3:

 * To use the -A (askpass) option, you need to install a compatible
 * password program from the following list. Starred packages will
 * automatically register for the use with sudo (but will not force
 * the -A option):
 *  [*] net-misc/ssh-askpass-fullscreen
 *      net-misc/x11-ssh-askpass
 * You can override the choice by setting the SUDO_ASKPASS environmnent
 * variable to the program you want to use.

 * Messages for package www-client/chromium-24.0.1312.56:

 * bindist disabled: Resulting binaries may not be legal to re-distribute.
 * Some web pages may require additional fonts to display properly.
 * Try installing some of the following packages if some characters
 * are not displayed properly:
 *  - media-fonts/arphicfonts
 *  - media-fonts/bitstream-cyberbit
 *  - media-fonts/droid
 *  - media-fonts/ipamonafont
 *  - media-fonts/ja-ipafonts
 *  - media-fonts/takao-fonts
 *  - media-fonts/wqy-microhei
 *  - media-fonts/wqy-zenhei

 * Messages for package net-misc/networkmanager-

 * One or more symlinks to directories have been preserved in order to
 * ensure that files installed via these symlinks remain accessible. This
 * indicates that the mentioned symlink(s) may be obsolete remnants of an
 * old install, and it may be appropriate to replace a given symlink with
 * the directory that it points to.
 *  /var/run

 * Messages for package net-misc/networkmanager-

 * To modify system network connections without needing to enter the
 * root password, add your user account to the 'plugdev' group.

 * Messages for package sys-kernel/calculate-sources-3.6.11:

 * !!! WARNING !!!  WARNING !!!  WARNING !!!  WARNING !!!
 * After the kernel assemble perform command to update modules:
 *   module-rebuild -X rebuild
 * QA Notice: ebeep is not defined in EAPI=4, please file a bug at http://bugs.gentoo.org
 * If you are upgrading from a previous kernel, you may be interested
 * in the following document:
 *   - General upgrade guide: http://www.gentoo.org/doc/en/kernel-upgrade.xml
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * Regenerating GNU info directory index...
 * Processed 8 info files.

!!! existing preserved libs:
>>> package: sys-fs/udev-197-r3
 *  - /lib64/libudev.so.0
 *  - /lib64/libudev.so.0.11.5
 *      used by /usr/lib64/gio/modules/libgvfsdbus.so (gnome-base/gvfs-1.12.3)
 *      used by /usr/lib64/libatasmart.so.4.0.5 (dev-libs/libatasmart-0.19)
 *      used by /usr/lib64/libva-dummy.so.1.3200.0 (x11-libs/libva-1.0.15)
 *      used by 4 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries

 * IMPORTANT: 2 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.

BTW I should post my current results of


And How do I determine Which are the 2 configuration files in /etc that I am warned to Update.
No Clue.
I did eliminate the new passwd_ and shadow_ and group_
Note the ending underscore in the name as they are different from the Originals.

bobssl410 sqlpython # eix-sync
Checking portage...
 * Copying old database to /var/cache/eix/previous.eix
 * Syncing all portage overlays

 * Fetching remote list,...
 * Remote list already up to date: http://www.gentoo.org/proj/en/overlays/repositories.xml
 * Last-modified: Mon, 28 Jan 2013 22:20:02 GMT
 * Fetch Ok

 * Syncing selected overlays,...
 * Running Git... # ( cd /var/lib/layman/calculate  && /usr/bin/git pull )
Already up-to-date.
 * Succeeded:
 * ------
 * Successfully synchronized overlay "calculate".

 * Running emerge --sync
>>> Starting git pull in /usr/portage...
Already up-to-date.
>>> Git pull in /usr/portage successful

* * IMPORTANT: 2 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.*
 * Running eix-update
Reading Portage settings ..
Building database (/var/cache/eix/portage.eix) ..
[0] "gentoo" /usr/portage/ (cache: metadata-md5-or-flat)
     Reading category 157|157 (100%) Finished             
[1] "calculate" /var/lib/layman/calculate (cache: parse|ebuild*#metadata-md5#metadata-flat#assign)
     Reading category 157|157 (100%) Finished          
Applying masks ..
Calculating hash tables ..
Writing database file /var/cache/eix/portage.eix ..
Database contains 16239 packages in 157 categories.
 * Update finished!
 * Calling eix-diff
Diffing databases (16239 -> 16239 packages)
 * Time statistics:
     2 seconds for syncing
     5 seconds for eix-update
     1 seconds for eix-diff
    15 seconds total
>>> package: sys-fs/udev-197-r3
 *  - /lib64/libudev.so.0
 *  - /lib64/libudev.so.0.11.5
 *      used by /usr/lib64/gio/modules/libgvfsdbus.so (gnome-base/gvfs-1.12.3)
 *      used by /usr/lib64/libatasmart.so.4.0.5 (dev-libs/libatasmart-0.19)
 *      used by /usr/lib64/libva-dummy.so.1.3200.0 (x11-libs/libva-1.0.15)
 *      used by 4 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries

Run <<emerge -a @preserved-rebuild>> to rebuild packages using these libraries.

If you see message like this:

IMPORTANT: 2 config files in '/etc' need updating.

Run <> to apply or zap new configs

Another Thank You, Yuri

I had already run

before I posted this thread and did not see configs lists…
Might be that I had removed passwd_ and shadow_ and group_ Files already.

Run emerge -a @preserved-rebuild to rebuild packages using these libraries.

Is a Big Help!!
I believed that I had to apply a
_emerge -a preserved-rebuild_ On a Per Package basis whenever I came across a package needing those particular Libraries. What you are saying is that I can rebuild ALL packages At One time referring to group of libraries needingpreserved… Correct?

Ok I ran a
emerge -a @preserved-rebuild

and the needed libraries were compiled in One move.
So that was good…

Then I again

and reminded that I now Had to /etc config files to take care of
.000cfg0000_mime.types and the original mime.types file
So once again I employed tkdiff to compare.

To correct the situation I ran
Then made the stupid error of choosing -5 I should have choosen -3 or -9 if unsure.
_Please select a file to edit by entering the corresponding number.
(don’t use -3, -5, -7 or -9 if you’re unsure what to do)
(-1 to exit) (-3 to auto merge all files)
(-5 to auto-merge AND not use ‘mv -i’)
(-7 to discard all updates)
(-9 to discard all updates AND not use ‘rm -i’): -5
Replacing /etc/mime.types with /etc/._cfg0000_mime.types
Exiting: Nothing left to do; exiting. :)_

Replacing /etc/mime.types with /etc/._cfg0000_mime.types
I had installed the WINE app manager CrossOver by codeweavers and that had mad entries in the /etc/mime.types.
I must have been getting tired when I choose -5 as the new mime.types now did not include the CrossOver mime types.
So I had to reinstall CrossOver
Next time I will choose -3

Good Night!