[Solved] nvidia resolution problem

I am used to run <<nvidia-xconfig --mode-list=1600x1200 1280x1024>> and my xfce gets these resolutions to list.
But it seems to not work in calculate.

How to set resolution in this case ?

This utility is in the package nvidia-settings. Install it:

emerge nvidia-settings

I have an intuition that nvidia-settings is not needed to run nvidia-xconfig
I installed it, but it is for another version 260, I have 173

If I remember coreectly sabayon is the one that worked with nvidia-xconfig without nvidia-settings.
And once I also had linux that allowed to run nvidia-settings in x server, but it was another version and did not have all functions.

I could try to restore sabayon partition and get the informations whether nvidia-settings is needed to allow nvidia-xconfig --mode-list=1600x1200 1280x1024 to work.

But I would think it does not need.

My only suggestions says, that calculate does not allow nvidia-xconfig --mode-list=1600x1200 to work.

I can run command without errors, but xfce does not show resolution.

You’re right, <<equery b /usr/bin/nvidia-xconfig>> shows that the utility is included in the package x11-drivers/nvidia-drivers. Calculate the driver in no way differs from the same driver in Gentoo, and I think in Sabayon, too. Try to copy the settings from the xorg.conf Sabayon.

I now dont remember whether Ive done it by nvidia-xconfig command or manually, but the xorg.conf has to be like this in my case.

 # nvidia-xconfig: X configuration file generated by nvidia-xconfig
 # nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Wed Sep 29 10:19:47 PDT 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
     # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
     # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
Modeline "1248x1024_75.00"  135.98  1248 1336 1472 1696  1024 1025 1028 1069  -HSync +Vsync 


Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
  Option     "NoLogo" "true"
Option "DynamicTwinView" "False"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024"
 Option           "AddARGBGLXVisuals" "true"    

Its about modeline setting

I now have full resolution in calculate.

This is solved


If only I would remember this, I would not have to make a topic because of a dump problem…
Thanks for help.