[SOLVED] mouse and keyboard not working

i installed CLD10.4 and updated it (emerge -uD world). after rebooting, the system boots till the kdm asks for username and password. in this step i noticed that the the mouse and keyboard is not working and i can not login to system!!!
it should be noted that at the first steps of boot a message about problem in plugdev (or udev) is appered but i had the same message before updating too and the system was working well.
i installed the CLDG10.4 in another partition and i have the same problem after updating CLDG too.

For setting the keyboard and mouse responds package sys-apps/hal. Once peace has been updated settings were overwritten. After the upgrade to the world to impose profiles “calculate -P all” and reboot system.
I think everything will work:)

How should i do login to the system? is it possible to boot another linux and execute the “calculate -P all” command after chroot to CLD?

I think it is easier to take the disk from which you are installing the system and boot from it. Must succeed.

after booting the system using CLD disk, i used a chroot to installed partition and applied “calculate -P all” command and this is the result:
Calculate 1.3.11
/proc/net/route: No such file or directory
Warning: cannot open /proc/net/dev (No such file or directory). Limited output.
cat: /proc/cmdline: No such file or directory
cat: /proc/cpuinfo: No such file or directory
pcilib: Cannot open /proc/bus/pci
pcilib: Cannot open /proc/bus/pci
Warning: cannot open /proc/net/dev (No such file or directory). Limited output.
/proc/net/route: No such file or directory
Apply template “install/1default”… done.
Apply template “install/2locale”… done.
Apply template “install/3patch”… done.
Apply template “install/4deprecated”… done.
Apply template “install/5compatible”… done.
Apply template “install/CLD”… done.
Apply template “install/desktop”… done.
but nothing changed and the problem still exist!!!
if i reinstall the system, should i prevent hal package to be updated? how?

Which commands has introduced that would go in chroot?
If you reinstall the system and renew the world to you after the upgrade will need to apply a profile, and then reboot.

how should i apply a profile?
i did not have this problem with CLDG10.4 beta1.
also i reinstalled CLDG and after rebooting i applied the following commands:
emerge portage
emerge -uD world
emerge -uD system
emerge hal

again after rebooting, the above problem created and i can not login to system.
Any solution?

Boot system with mouse problem specify boot parameter ‘nox’. (Grub,‘e’,select second line ‘e’, append nox,‘b’). System started without xserver. Perform by root

calculate -P all
/etc/init.d/dbus restart
/etc/init.d/hald restart
/etc/init.d/xdm restart

after booting the system with nox option and login as root, when i restart the dbus, the x is started and kdm screen comes up while the keyboard and mouse are not working!!! applying hald or xdm have a same result. it seems the “calculate -P all” can not remove the problem.

What is version of hald you use? Please attach /etc/X11/xorg.conf file.

regarding “emerge --search hal” the last version of sys-apps/hal is 0.5.13-r2.
regarding “emerge --search udev” the last version of sys-fs/udev is 149.
the /etc/X11/xorg.conf file is empty. as i know the new xorg does not use this file anymore.

i reinstalled the CLD. how can i update the system not to have the above problem?

What would have worked as a mouse and keyboard.

  1. need to rebuild udev use +extras
  2. rebuild xorg-server c use -hal +udev
    remove hald of startup and add udev
    qfile -I -C x11-drivers/
    displays a list of packages that need to rebuild:)
    rebuild and everything nice)

i added the following lines to /etc/portage/package.use/using:
sys-fs/udev extras
x11-base/xorg-server -hal udev

i emerged udev successfully, but emerge x11-base/xorg-server results in following error messages:

calculate ~ # emerge x11-base/xorg-server

* IMPORTANT: 3 news items need reading for repository ‘gentoo’.
* Use eselect news to read news items.

Calculating dependencies… done!
[ebuild U ] x11-proto/xextproto-7.1.1 [7.0.5]
[ebuild U ] x11-proto/fixesproto-4.1.1 [4.0]
[ebuild U ] x11-base/xorg-drivers-1.7 [1.6]
[uninstall ] x11-drivers/xf86-input-mutouch-1.2.1
[blocks b ] x11-drivers/xf86-input-mutouch (“x11-drivers/xf86-input-mutouch” is blocking x11-base/xorg-drivers-1.7)
[ebuild U ] x11-proto/xf86vidmodeproto-2.3 [2.2.2]
[uninstall ] x11-libs/libXxf86vm-1.0.2
[blocks b ] <x11-libs/libXxf86vm- ("<x11-libs/libXxf86vm-" is blocking x11-proto/xf86vidmodeproto-2.3)
[ebuild U ] x11-proto/recordproto-1.14 [1.13.2]
[uninstall ] x11-libs/libXtst-1.0.3
[blocks b ] <x11-libs/libXtst- ("<x11-libs/libXtst-" is blocking x11-proto/recordproto-1.14)
[ebuild U ] x11-proto/inputproto-2.0 [1.5.1]
[uninstall ] x11-libs/libXi-1.2.1
[blocks b ] <x11-libs/libXi-1.2.99 ("<x11-libs/libXi-1.2.99" is blocking x11-proto/inputproto-2.0)
[ebuild U ] x11-proto/xineramaproto-1.2 [1.1.2]
[uninstall ] x11-libs/libXinerama-1.0.3
[blocks b ] <x11-libs/libXinerama- ("<x11-libs/libXinerama-" is blocking x11-proto/xineramaproto-1.2)
[ebuild U ] x11-proto/xf86dgaproto-2.1 [2.0.3]
[uninstall ] x11-libs/libXxf86dga-1.0.2
[blocks b ] <x11-libs/libXxf86dga- ("<x11-libs/libXxf86dga-" is blocking x11-proto/xf86dgaproto-2.1)
[ebuild U ] x11-base/xorg-server-1.7.6 [1.6.5-r1] USE="-hal*"
[blocks B ] <x11-libs/libXext-1.0.99 ("<x11-libs/libXext-1.0.99" is blocking x11-proto/xextproto-7.1.1)

  • Error: The above package list contains packages which cannot be
  • installed at the same time on the same system.

(‘ebuild’, ‘/’, ‘x11-proto/xextproto-7.1.1’, ‘merge’) pulled in by
>=x11-proto/xextproto- required by (‘ebuild’, ‘/’, ‘x11-proto/fixesproto-4.1.1’, ‘merge’)

=x11-proto/xextproto- required by (‘ebuild’, ‘/’, ‘x11-base/xorg-server-1.7.6’, ‘merge’)

(‘installed’, ‘/’, ‘x11-libs/libXext-1.0.5’, ‘nomerge’) pulled in by

=x11-libs/libXext-1.0.5 required by (‘ebuild’, ‘/’, ‘x11-base/xorg-server-1.7.6’, ‘merge’)

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):


* IMPORTANT: 3 news items need reading for repository ‘gentoo’.
* Use eselect news to read news items.

qfile has no -I option and does not work. also, “qfile -C x11-drivers/” gives nothig!!!

so i applied:
rc-update add udev
rc-update del hald
emerge -uD world

i am waiting for the result after a reboot. hope it works!!!

Well, all right. You want what I would have explained how to remove packages? The fact that blocked prowess, and then pick up as needed.
command qlist -I -C x11-drivers/

after the above commands and a system reboot, the problem repeated and the mouse and keyboard do not work on login screen!!! what is the problem? any idea?

I have the same problem.
Xorg.0.log says module “evdev” version mismatch.
compiled for 1.6.5 …
X -version is 1.7.6

No solution yet, but that is the problem.

A simple re-emerge fixed the problem for me.

#emerge xf86-input-evdev

This recompiled for current Xorg version,
and the mouse and keyboard works now.

Update portage, calculate overlay and world.

emerge -uD world

yes, the updated layman solved the problem.