[SOLVED] Installation problem when using already existing partitions

While trying to install CLDX 17.12.2, when I get to the step of defining the mount points, after choosing to use the already existing partitions, it seems that I’m not able to find what are the correct options to choose.

The partitions I’m trying to use, are the ones that are listed by GParted as the following, when using Debian: https://postimg.cc/18gxhPmX (And the following, when using the live CLDX installation medium: https://postimg.cc/ftfpjRK2)

And, the options I try to use, in order to mimic what is displayed by GParted, and what I’ve seen other installation programs doing, are the following: https://postimg.cc/0bQFDxJn

But, after clicking “Next”, I get the following error messages: https://postimg.cc/Jyb2Mz9r

And, if I click to show the advanced settings and then click again to hide then, the partition table is then shown as the following, with several options that were added automatically by the installer: https://postimg.cc/9wf8dtz0

Note: I’m using a motherboard with an “old” (non-UEFI) type of BIOS, and a hard drive with a GPT partitioning scheme. And, my “sda1” partition is one that I created with gdisk (a long time ago, and that has been used, with no problems, by other GNU/Linux installers) choosing the “EF02” label - since, this is the type of partition required for motherboards with an “old” type of BIOS to boot, when using a “GUID Partition Table” (GPT).

One thing I would like to add, is that,

The first time I tried CLDX (version 17) over a year ago, when I got to this “mount points” step, although GParted would automatically detect my partitions, the graphical installer apparently wouldn’t (i.e. the “mount points” list appeared empty, when I reached this step). And, after having the opportunity to test the next stable build (17.6 version) of CLDX, the graphical installer would then already automatically detect my partitions, when I reached this “mount points” step.

(“Firefox Screenshot” of the deleted forum topic about this: https://postimg.cc/kVyBccrQ)

And, with this new graphical installer (of the 17.12.2 version) of CLDX, although the same thing happens (of my partitions not being automatically listed - contrary to what happens when I use every other GNU/Linux graphical installer), because I decided to test the buttons next to where the partitions list should appear, I noticed that, if I repeatedly press the “+” button, the installer offers to “create” the same partitions (i.e. partitions of the same size and type, of what) I already have on my disk (and, this is how I was now able to apparently “solve” this problem).

And, all this to say that,

There seems to be a problem with the graphical installer, that has appeared again in this new (17.12.2) version of CLDX, that causes the existing partitions to not be automatically listed by the installer (at least, when using the type of partition scheme - “old” BIOS + GPT - that I use) - that, if it happens also to another person, apparently you can tell such person to “solve” it by pressing the “+” button, to “create” the already existing partitions.

Problem with layout was caused by adding to list partitions, which you do not use (/dev/sda1,/dev/sda4). If you want to use the partition as swap, you should select mount point “swap”. In this way you need to choose to follow partitions and mount points:

/dev/sda2   /      ext4
/dev/sda3   /home  ext4
/dev/sda4   swap   swap

Aha! You were right, Mikhail Hiretsky. :slight_smile:

Because, with the installers of the Debian family of distros, I always choose the option “Use as: Reserved BIOS boot area” for my /sda1 partition, I thought I had to also choose to “use” such partition with Calculate’s installer. But, just ignoring the partition, as you said, solves the problem - since, the installer later automatically chooses to install GRUB on my (sda) disk.

(The following was then the partitions list I created, and everything went fine from there on: https://postimg.cc/MnDD78Kd)

Thank you very much for your help, Mikhail Hiretsky.

I’m now already using, and starting to tweak, this most promising “systemd-free” distro! :slight_smile: