[Solved] CLDM: dev-libs/mathjax-3 forced by app-text/atril-1.26.2

Hi Calculate Team <3,

On my up to date CLDM (so Mate) I have the package app-text/atril-1.26.2 who force the package dev-libs/mathjax at version 3.
I do believe it should be 3.2.2-r1 instead of just 3.
cl-update is not blocking the system works flawlessly however it block me for the installation of calibre to manage my e-books :slight_smile:

I have 2 questions:

  • Firstly do you agree with the statement (atril should ask for mathjax 3.2.2-r1 instead of just 3)?
  • Secondly: if yes could you please update the dependency?

As usual Thanks a lot for your huge work on Calculate Linux <3

Peace! <3

i simply write to my /etc/portage/package.use/app-text

# epub - app-text/atril 1.26.1 1.27.0 [epub] need “<dev-libs/mathjax-3”
# dev-libs/mathjax-3.2.2 need for app-text/calibre-7.2.0 [system-mathjax]
app-text/atril caja dvi synctex t1lib xps
<=app-text/atril-1.27.0 -epub


Thanks for the very quick answer!
If I may, could you please explain a bit your answer, I am not sure to understand what the lines are doing.
To detail:
the lines who start by # are only comment aren’t they?
Why adding the use caja dvi synctex t1lib xps to atril and remove the epub?

I am not saying it doesn’t work I am just trying to understand what does it do :slight_smile:


This is really a comment. For further understanding why it is written here.

I need it so much ((( Only i — NOT you )))

This resolves dependencies.
I need this for now. My priority - app-text/calibre

But for your system, you are the Administrator - you decide what to do.

Maybe atril-1.28-1.30 will learn to work with epub via “>=dev-libs/mathjax-3”

Thanks a lot Alex!
You were super fast, super cool and super efficient.
It works perfectly and I was blocked with calibre 5x and now I have calibre 7.5.
I enjoy calibre also :slight_smile:
Really thank you <3 :+1: