[solved] Alt+F2 switch to TTY2....

Hi all,

Since i reinstalled CL (with CLSK image) when i try to launch with Alt+F2 the Search tool of plasma, my laptop switch to TTY2…

No problems with ATL+F2 from the external keyboard, but with the laptop keyborad, Alt+F2 switch to TTY2…

How can we solve the problem ?


I add this line :

  Option "GrabDevice" "True"

in the /etc/X11/xorg.conf.d/keyboard.conf file

Full example :

1 [13:40:41] adrien@superlinux: ~  $ cat /etc/X11/xorg.conf.d/keyboard.conf 
 # Modified Calculate-core
 # Processed template files:
 # /var/lib/layman/calculate/profiles/templates/3.3/3_ac_install_live/1-merge/x11-base/xorg-server/X11/xorg.conf.d/keyboard.conf
 # For modify this file, create /etc/X11/xorg.conf.d/keyboard.conf.clt template.

 # Keyboard settings
Section "InputClass"
  Identifier  "keyboard"
  Driver  "evdev"
  Option  "Protocol" "event"
  MatchIsKeyboard "1"
  Option "XkbLayout" "fr"
  Option "XkbOptions" "grp:caps_toggle,grp_led:scroll"
  Option "GrabDevice" "True"

Add it now, thank you!

We disabled this option, because it cause the typing problem on TTY1 terminal.