Calculate🐧Forum

[Résolu] Problème installation Wifi

#1

Bonjour à tous,

J’ai installé Calculate Linux depuis peu, et la seule chose récalcitrante est le support du wifi.

La carte PCi est une 23:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)

23:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)
        Subsystem: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter [14e4:0619]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 31
        Region 0: Memory at fd400000 (64-bit, non-prefetchable) [size=32K]
        Region 2: Memory at fd200000 (64-bit, non-prefetchable) [size=2M]
        Capabilities: [48] Power Management version 3
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
                Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=2 PME-
        Capabilities: [58] MSI: Enable- Count=1/1 Maskable- 64bit+
                Address: 0000000000000000  Data: 0000
        Capabilities: [68] Vendor Specific Information: Len=44 <?>
        Capabilities: [ac] Express (v2) Endpoint, MSI 00
                DevCap: MaxPayload 256 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset- SlotPowerLimit 26.000W
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd+ ExtTag- PhantFunc- AuxPwr+ NoSnoop+
                        MaxPayload 128 bytes, MaxReadReq 512 bytes
                DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <2us, L1 <32us
                        ClockPM+ Surprise- LLActRep- BwNot- ASPMOptComp+
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- CommClk+
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
                DevCap2: Completion Timeout: Range ABCD, TimeoutDis+, LTR+, OBFF Via WAKE#
                         AtomicOpsCap: 32bit- 64bit- 128bitCAS-
                DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR-, OBFF Disabled
                         AtomicOpsCtl: ReqEn-
                LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-
                         Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
                         Compliance De-emphasis: -6dB
                LnkSta2: Current De-emphasis Level: -3.5dB, EqualizationComplete-, EqualizationPhase1-
                         EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
        Capabilities: [100 v1] Advanced Error Reporting
                UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
                CESta:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
                CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
                AERCap: First Error Pointer: 00, ECRCGenCap+ ECRCGenEn- ECRCChkCap+ ECRCChkEn-
                        MultHdrRecCap- MultHdrRecEn- TLPPfxPres- HdrLogCap-
                HeaderLog: 00000000 00000000 00000000 00000000
        Capabilities: [13c v1] Device Serial Number 50-3e-00-ff-ff-00-00-00
        Capabilities: [150 v1] Power Budgeting <?>
        Capabilities: [160 v1] Virtual Channel
                Caps:   LPEVC=0 RefClk=100ns PATEntryBits=1
                Arb:    Fixed- WRR32- WRR64- WRR128-
                Ctrl:   ArbSelect=Fixed
                Status: InProgress-
                VC0:    Caps:   PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
                        Arb:    Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
                        Ctrl:   Enable+ ID=0 ArbSelect=Fixed TC/VC=01
                        Status: NegoPending- InProgress-
        Capabilities: [1b0 v1] Latency Tolerance Reporting
                Max snoop latency: 0ns
                Max no snoop latency: 0ns
        Capabilities: [220 v1] #15
        Kernel driver in use: bcma-pci-bridge
        Kernel modules: bcma, wl

J’ai installé

net-wireless/broadcom-sta
net-wireless/bcm43xx-fwcutter

et ensuite procedé à l’activation et désactivation de modules

modprobe -r b43 b44 b43legacy ssb brcmsmac
modprobe bcma wl

Quand je fait un iwconfig, j’ai juste droit à “no wireless extensions”. Je précise que pour la gestion du réseau, j’utilise NetworkManager.

Auriez vous des pistes à me proposer ?

Merci

#2

Bonjour,
Je n’ai pas ce type de carte donc pas possible de tester mais il me semble que seul broadcom-sta est nécessaire.
Je te laisse désinstaller l’autre paquet.

Il ne faut en revanche pas utiliser b43 et sbb.

Juste en créant un fichier /etc/modprobe.d/blacklist.conf et en mettant les 2 modules ainsi

blacklist b43
blacklist sbb 

Et en rebootant, ça doit le faire. NetworkManager sera dans la possibilité de configurer la connexion WiFi.

A tester

#3

Bonjour,

Solution testée à l’instant et ça ne change rien. Du coup, j’ai tout désinstallé et réinstallé le paquet broadcom-sta et je suis tombé sur ce message

 *   B43: If you insist on building this, you must blacklist it!
 *   BCMA: If you insist on building this, you must blacklist it!
 *   SSB: If you insist on building this, you must blacklist it!
 *   X86_INTEL_LPSS: Please disable it. The module does not work with it enabled.
 *   MAC80211: If you insist on building this, you must blacklist it!
 *   PREEMPT_RCU: Please do not set the Preemption Model to "Preemptible Kernel"; choose something else.
 *   CONFIG_PREEMPT:     should not be set. But it is.
 * Please check to make sure these options are set correctly. 

J’ai donc blacklisté tout les modules qu’il indiquait (b43,bcma,ssb,x86_intel_lpss,mac80211) et ça fonctionne.

Comme quoi, il faut toujours lire les message d’avertissement !!!

Mastodon Mastodon