Calculate Forum

Résolu: Emerge n'arrive pas à trouver la version du noyeau

Bonjour,

Depuis 2 jours, je n’arrive plus à faire certaines mise-à-jour, nommément Firefox-bin-92 et qemu-6.0.0-r53 ou encore virtualbox (ajout: maintenant s’ajoutent libvirt et associés). Même chose si j’essaie de les installer directement avec emerge.
Dans tous les cas lee message d’erreur est qu’il est impossible de déterminer la version du noyeau.
Je suis sur “testing”.

Est-ce que cela pourrait avoir un lien avec ce bug ?
https://bugs.gentoo.org/726314
Bug 726314 - linux-info.eclass: Unable to determine any Linux Kernel version

Merci d’avance.

Informations sur mon installation:

Résultat de readlink:
calculate # readlink /usr/src/linux
linux-5.14.2-calculate

Système d’exploitation : Calculate Linux
Version de KDE Plasma : 5.22.5
Version de KDE Frameworks : 5.85.0
Version de Qt : 5.15.2
Version de noyau : 5.14.2-calculate (64-bit) (même problème avec 5.14.3 et 5.13.16)
Plate-forme graphique : X11
Processeurs : 12 × 11th Gen Intel® Core™ i5-11400 @ 2.60GHz
Mémoire : 15.3 Gio de mémoire vive
Processeur graphique : Mesa Intel® Graphics

Résultat de readlink:
calculate # readlink /usr/src/linux
linux-5.14.2-calculate

J’ai placé les informations de emerge dans les fichiers joints pour éviter d’allonger inutilement ce message:

Problème emerge-kernel version.txt: le message d’emerge et son résultat de même que le résultat de
emerge --info ‘=www-client/firefox-bin-92.0-r1::gentoo’
Problème emerge-kernel version.txt (12,1 Ko)
Firefox-bin_build.log (2,0 Ko)
Firefox-bin_die.env (251,2 Ko)

Run the command ls -la /usr/src/linux-5.14.2-calculate
and show the output, or re-create the kernel object reference.

Problème résolu: j’ai changé le “drapeau” +minimal pour -minimal dans package.use et tout est revenu à la normale.
Merci.

© 2007-2020 Calculate Ltd.
Mastodon Mastodon