Calculate Forum

Проблема в ненужном pulseaudio

У меня глобально, через USE отключён pulseaudio, всё собрано без него.

И вот сейчас вылезла проблема, что система не хочет обновляться, требуя его установить:

* Проверка текущего сервера обновлений ...                                                                                                                                                                                           [ ok ]
* Проверка обновлений Distros ...                                                                                                                                                                                                    [ ok ]
* Проверка обновлений Calculate ...                                                                                                                                                                                                  [ ok ]
* Проверка обновлений Gentoo ...                                                                                                                                                                                                     [ ok ]
* Синхронизация завершена
Конфигурация системы
* Сервер обновлений https://mirror.yandex.ru/calculate
Обновление пакетов
* Вычисление зависимостей ...                                                                                                                                                                                                        [ ok ]

^^^^^^^^
(and 8 more with the same problem)

(dev-lang/perl-5.32.1:0/5.32::gentoo, installed) USE="berkdb gdbm ithreads -debug -doc -minimal" ABI_X86="(64)" pulled in by
dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/XML-Parser-2.440.0:0/0::gentoo, installed) USE="" ABI_X86="(64)"
^^^^^^^^
(and 12 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

emerge: there are no ebuilds built with USE flags to satisfy "media-plugins/alsa-plugins[abi_x86_64(-),pulseaudio]".
!!! One of the following packages is required to complete your request:
- media-plugins/alsa-plugins-1.2.2::gentoo (Change USE: +pulseaudio)
(dependency required by "media-video/pipewire-0.3.30-r2::gentoo" [binary])
(dependency required by "sys-apps/xdg-desktop-portal-1.8.1::gentoo" [installed])
(dependency required by "kde-plasma/xdg-desktop-portal-kde-5.21.5::gentoo" [installed])
(dependency required by "kde-plasma/plasma-meta-5.21.5::gentoo[desktop-portal]" [installed])
(dependency required by "kde-apps/kdebase-meta-19.08.3::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
* Выполнение Emerge завершилось с ошибкой
* Не удалось обновить

perl тут ни при чём, хотя я для проверки даже сделал emerge -av dev-lang/perl - тут просто поверх его перезаписало, ту же версию, и всё

Зачем было для alsa-plugins выставлять жёсткое требование PA?

Этот вопрос задайте там.

© 2007-2020 Calculate Ltd.
Mastodon Mastodon