Calculate Forum

Prooblem de mise a jour

salut je voulais mettre a jour mon calculate xfce, voici se qu’il m’affiche:
calculate masse # cl-update
Synchronisation des dépôts

  • Vérification du dépôt actuel … [ ok ]
  • Vérification des mises à jour de Distros … [ ok ]
  • Vérification des mises à jour de Calculate … [ ok ]
  • Vérification des mises à jour de Gentoo … [ ok ]
  • Synchronisation terminée
    Configuration système
  • Serveur de mise à jour http://www.gtlib.gatech.edu/pub/calculate
    Mise à jour des paquets
  • Calcul des dépendances … [ ok ]

(dev-perl/Parse-Yapp-1.210.0:0/0::gentoo, installed): ebuild is masked or unavailable

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

!!! All ebuilds that could satisfy “>=dev-perl/HTTP-Message-6.0.0” have been masked.
!!! One of the following masked packages is required to complete your request:

  • dev-perl/HTTP-Message-6.320.0::gentoo (masked by: EAPI 8)
  • dev-perl/HTTP-Message-6.320.0 (masked by: EAPI 8)

The current version of portage supports EAPI ‘7’. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by “dev-perl/libwww-perl-6.530.0::gentoo” [ebuild])
(dependency required by “dev-perl/XML-Parser-2.460.0::gentoo” [binary])
(dependency required by “dev-util/intltool-0.51.0-r2::gentoo” [binary])
(dependency required by “xfce-base/thunar-4.16.8::gentoo” [ebuild])
(dependency required by “xfce-extra/thunar-volman-4.16.0::gentoo” [installed])
(dependency required by “@selected” [set])
(dependency required by “@world” [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

  • Emerge a échoué
  • Mise à jour échouée"

aisez-moi je vous en prie

Peut-être faut-il désinstaller dev-perl/Parse-Yapp, faire la mise à jour et le réinstaller après?

merci. je l’ai désinstallé mais maintenant il m’affiche:
calculate masse # cl-update
Synchronisation des dépôts

  • Vérification du dépôt actuel … [ ok ]
  • Vérification des mises à jour de Distros … [ ok ]
  • Vérification des mises à jour de Calculate … [ ok ]
  • Vérification des mises à jour de Gentoo … [ ok ]
  • Synchronisation terminée
    Configuration système
  • Serveur de mise à jour http://www.gtlib.gatech.edu/pub/calculate
    Mise à jour des paquets
  • Calcul des dépendances … [ ok ]

(x11-base/xorg-server-1.20.13-r1:0/1.20.13::gentoo, binary scheduled for merge) USE=“elogind ipv6 kdrive udev xorg xvfb -debug -dmx -doc -minimal (-selinux) -suid (-systemd) -test -unwind -xcsecurity -xephyr -xnest” ABI_X86="(64)" pulled in by
x11-base/xorg-server:0/1.20.13= required by (x11-drivers/xf86-video-qxl-0.1.5_p20200205:0/0::gentoo, binary scheduled for merge) USE="-xspice" ABI_X86="(64)" PYTHON_SINGLE_TARGET=“python3_9 -python3_8”
^^^^^^^^^^^
(and 1 more with the same problem)

(x11-base/xorg-server-1.20.11:0/1.20.11::gentoo, ebuild scheduled for merge) USE=“elogind ipv6 kdrive udev wayland xorg xvfb -debug -dmx -doc -minimal (-selinux) -suid (-systemd) -test -unwind -xcsecurity -xephyr -xnest” ABI_X86="(64)" pulled in by
x11-base/xorg-server:0/1.20.11= required by (x11-drivers/xf86-video-nouveau-1.0.17:0/0::gentoo, installed) USE="" ABI_X86="(64)"
^^^^^^^^^^^
(and 12 more with the same problem)

NOTE: Use the ‘–verbose-conflicts’ option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

The following keyword changes are necessary to proceed:
(see “package.accept_keywords” in the portage(5) man page for more details)

required by net-libs/libsoup-2.72.0-r1::gentoo

required by xfce-extra/xfce4-screenshooter-1.9.9::gentoo

required by @selected

required by @world (argument)

=net-fs/samba-4.14.7 ~amd64

  • Emerge a échoué
  • Mise à jour échouée"

que faire maintenant? svp.

Jette un coup d’oeil sur ce site :

pardon : Utiliser Gentoo et Calculate Linux - Wiki - Wiki. Refaire une installation propre et surtout sauvegarder les données personnelles auparavant.

je viens tout juste de l’installer. c’est ce matin que j’ai telecharger l’iso de calculate linux xfce et je l’ai installer

© 2007-2020 Calculate Ltd.
Mastodon Mastodon