Problem with BCM4313


I am new on planet calculate, and I have some difficulties to enable WiFi on my laptop.
Here is the desciption of the network part of lshw

description: Network controller
product: BCM4313 802.11b/g LP-PHY
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:12:00.0
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=bcma-pci-bridge latency=0
resources: irq:17 memory:fbc00000-fbc03fff

I tried to use ndiswrapper with bcmwl6.inf and nothing…
I don’t really know how to proceed but it seems that the firmware for BCM4313 is still not developed by Boadcom.

I would be really thankful if one of you could help me solving this annoying problem.



This card must be supported by net-wireless/broadcom-sta driver, but may be a problem with > 3.0 kernels.
You can try this solution or you can mask > 3.0 kernels.

First of all, thank you for your answer Yuri.
I tried to follow the guide.

I first removed bcma. I then noticed wl.ko was not available so I downloaded it from :


I then launched the makefile via make and obtained the following log :

KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: Entering directory `/usr/src/linux-3.0.4-calculate'

  WARNING: Symbol version dump /usr/src/linux-3.0.4-calculate/Module.symvers
           is missing; modules will have no dependencies and modversions.

  CC [M]  /home/guest/Downloads/broadcom/src/wl/sys/wl_linux.o
/home/guest/Downloads/broadcom/src/wl/sys/wl_linux.c: In function ‘wl_attach’:
/home/guest/Downloads/broadcom/src/wl/sys/wl_linux.c:485:3: error: implicit declaration of function ‘init_MUTEX’
make[2]: *** [/home/guest/Downloads/broadcom/src/wl/sys/wl_linux.o] Error 1
make[1]: *** [_module_/home/guest/Downloads/broadcom] Error 2
make[1]: Leaving directory `/usr/src/linux-3.0.4-calculate'
make: *** [all] Error 2

I have knowledge in C, but I don’t think I will be able to debug this myself… Maybe are you familiar with this problem?

If you want build driver from the source you must apply this patch

What version of Calculate Linux you use? What version of the kernel?

I am using the last version of Linux Desktop (11.9 KDE) and my Kernel is 3.0.4.
I am checking your link, thanks.


Ok I patched the driver but there is still an issue. I am kind of unlucky I guess…
The new result of the makefile seemed encouraging :

KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: Entering directory `/usr/src/linux-3.0.4-calculate'

  WARNING: Symbol version dump /usr/src/linux-3.0.4-calculate/Module.symvers
           is missing; modules will have no dependencies and modversions.

  Building modules, stage 2.
  MODPOST 1 modules
WARNING: modpost: missing MODULE_LICENSE() in /home/guest/Downloads/broadcom/wl.o
see include/linux/module.h for more information
make[1]: Leaving directory `/usr/src/linux-3.0.4-calculate'

but when I tried the command “insmod wl.ko”, I had the following error:

insmod: error inserting 'wl.ko': -1 Unknown symbol in module

I am trying to fix it…

In a few hours i’ll upgrade system on my laptop(with BCM4312). Let’s see how the driver will behave on it.
In the evening I will write what the results will be.

Ok, thanks again!

I am currently following the advices of this README edited by Broadcom :


And why you are trying build from the source?

 # qlist net-wireless/broadcom-sta

net-wireless/broadcom-sta package install module in
/lib/modules/3.0.4-calculate/net/wireless/wl.ko and it must work


 # rmmod b43
 # rmmod bcma
 # rmmod wl


modprobe wl


insmod /lib/modules/3.0.4-calculate/net/wireless/wl.ko


calculate / # iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11  ESSID:""  Nickname:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Bit Rate:72 Mb/s   Tx-Power:24 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Power Managementmode:All packets received
          Link Quality=5/5  Signal level=0 dBm  Noise level=-12 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

The README file explains it all.
Some issues at reboot… not working again…
Wifi on calculate is my vietnam…
I’ll try to do once again the procedure.

Good evening and once again : spaciba!

Are you blacklisted b43 and bcma modules?
This is necessary to prevent modules loading.

Just add this lines to /etc/modprobe.d/blacklist.conf:

blacklist bcma
blacklist b43

Hi Yuri,

I have the same issue but rmmod bcma and modprobe wl work well for me. The only problem that the blacklist seems to be not working for me. I have following:

calculate home # cat /etc/modprobe.d/blacklist.conf 
blacklist bcma
blacklist b43

But after reboot, bcma is loaded again while wl not. What is wrong here?

Aleksey Koltsov