problem starting kde


yesterday evening upgrade (i can’t remember which software, but let’s say no more then 10 apps) seems ok. shutdown works ok. and todays reboot doesn’t work at all. not even calculate safe boot. seems problem with nvidia as i can tell. looks like kde want to start but i get only black screen. strange i can’t enter tty either so i can’t see logs. maybe i should edit cl for boot but i don’t know what to delete (tried with removing calculate=video:nvidia but no effect) and what to add so i have only command line. any help?


ok so i added nox at the end of line and i get command line only. login and dmesg shows no errors or smthg similar for anything. just a note that nvidia console driver is not set to vga (smthg like that). then i run cl-update and no updates. after that startx started my kde from which i am writing this. i will see on next reboot…

thanks for reading

because of smthg that i don’t know what is everything is ok now…

well problem is not solved. again black screen (was some update last night). with nox i started in console. login as user. startx command and i am in kde…what is the problem?


Hi !

I think it’s a problem with recent GCC Update.

Sync your tree and rebuild all deps depending of GCC :

revdep-rebuild --library '' -- --exclude gcc

After, reboot

2 reboots…seems fine for now…thanks Adrien

Cool :slight_smile:

hm problem occure yesterday again. i will try again your fix Adrien…

Normally, my “fix” is only for the GCC update.

You have probably some problems with your distro?

Try to reemerge all binaries and check if there are errors :

emerge -e @world

i did this yesterday and today’s 1st run seems ok. in kde without problem. we’ll see what will happened after next upgrade and then reboot…

thanks again Adrien