Calculate Forum

Portage upgrade problem

Hi
I did not used komputer for a long time
Now i would like to upgrade 20.0 to 20.06 ( MATE )
But i cant upgrade portage oneshot and cl-update

emerge --ask --oneshot sys-apps/portage

Calculating dependencies... done!
[ebuild     U ~] sys-apps/portage-2.3.101-r2 [2.3.89-r1] PYTHON_TARGETS="python3_7* -python3_6* -python3_9%" 

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/portage:0

  (sys-apps/portage-2.3.101-r2:0/0::gentoo, ebuild scheduled for merge) USE="(ipc) native-extensions xattr -apidoc -build -doc -gentoo-dev -rsync-verify (-selinux)" ABI_X86="(64)" PYTHON_TARGETS="python3_7 -pypy3 -python3_6 -python3_8 -python3_9" pulled in by
    sys-apps/portage (Argument)

  (sys-apps/portage-2.3.89-r1:0/0::gentoo, installed) USE="(ipc) native-extensions xattr -apidoc -build -doc -gentoo-dev -rsync-verify (-selinux)" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7 (-python3_8)" pulled in by
    >=sys-apps/portage-2.1[python_targets_python2_7(-),-python_single_target_python2_7(-)] required by (app-portage/porthole-0.6.1-r5:0/0::gentoo, installed) USE="nls" ABI_X86="(64)" PYTHON_TARGETS="python2_7"
                                                                                                                                                                                                                                                                                           
    sys-apps/portage[python_targets_python2_7] required by (sys-apps/calculate-utils-3.6.7.21:3/3::calculate, installed) USE="backup client console dbus desktop gpg install qt5 -minimal -pxe (-server)" ABI_X86="(64)" PYTHON_TARGETS="python2_7"
                     ^^^^^^^^^^^^^^^^^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 
    sys-apps/portage[python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (app-portage/gentoolkit-0.4.6:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python3_6 -python3_7"
                                                                                                                                                                                                                                                                                                                                                             


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by app-admin/haskell-updater-1.3.1::gentoo
# required by dev-lang/ghc-8.0.2::gentoo[-ghcbootstrap]
# required by dev-haskell/cereal-0.4.1.1::gentoo
# required by dev-haskell/dbus-0.10.13::gentoo
# required by @selected
# required by @world (argument)
=sys-apps/portage-2.3.101-r2 ~amd64

Would you like to add these changes to your config files? [Yes/No] n

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! The following installed packages are masked:
- dev-ruby/did_you_mean-1.1.2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Hans de Graaff <graaff@gentoo.org> (2020-06-14)
# Ruby 2.4 is no longer supported by upstream and no longer gets
# security updates since the 2.4.10 release. Use ruby 2.5 or later
# instead.

- dev-lang/ruby-2.4.9::gentoo (masked by: package.mask)
- sys-libs/glibc-2.29-r7::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (2017-05-21 and later updates)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

Hi, First update the sys-apps/calculate-utils package.

upgraded, emerge --ask --oneshot calculate-utils ( works )
and then emerge --ask --oneshot sys-apps/portage ( not working )

still error portage

or cl-update
The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by app-admin/haskell-updater-1.3.1::gentoo
# required by dev-lang/ghc-8.0.2::gentoo[-ghcbootstrap]
# required by dev-haskell/cereal-0.4.1.1::gentoo
# required by dev-haskell/dbus-0.10.13::gentoo
# required by @selected
# required by @world (argument)
=sys-apps/portage-2.3.101-r2 ~amd64
 * Emerge failed
 * Update failed

system ask me to keyword changes till portage 999

If the system has not been updated for a long time, you should update the set @world. It is easier to do this by doing the cl-update.

Before that delete all changes on /etc/portage/package.use/* and /etc/portage/package.accept_keywords/*.

I booted CLDM 20 release to VirtualBox, then run cl-update - I had no error.

cl-update --rebuild world resolved problem
Than you very much
bye bye

1 Like
© 2007-2020 Calculate Ltd.
Mastodon Mastodon