Calculate Forum

Нужна помощь! по Plymouth

Привет всем!

не обновляется Plymouth, ввожу команду emerge -uDN world, и вижу это.

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

sys-boot/plymouth:0

(sys-boot/plymouth-0.9.5-r1:0/0::gentoo, ebuild scheduled for merge) USE=“gtk libkms pango (split-usr) udev -debug -static-libs” ABI_X86="(64)" conflicts with
~sys-boot/plymouth-0.9.4[gtk,libkms,pango,split-usr] required by (sys-boot/plymouth-calculate-plugin-0.9.4-r3:0/0::calculate, installed) USE=“gtk libkms pang
o (split-usr) -debug -gdm -static-libs” ABI_X86="(64)"
^ ^^^^^

В чём загвоздка, не могу понять, подскажите

sys-boot/plymouth
      Latest version available: 0.9.5-r1
      Latest version installed: 0.9.4-r1
      Size of files: 1173 KiB
      Homepage:      https://cgit.freedesktop.org/plymouth/
      Description:   Graphical boot animation (splash) and logger
      License:       GPL-2

Уже появилась новая версия, но обновы не происходит.
https://old.calculate-linux.org/packages/sys-boot/plymouth
Видимо еще не успела выйти новая версия sys-boot/plymouth-calculate-plugin вот и конфликт.

То что это разница в версиях, эт понятно, из-за этого обновление с команды emerge -uDN world стопорится.

Всё равно спасибо, будем ждать обновки

Не должно быть блокировки, хоть есть стабильная версия 0.9.5, пакет sys-boot/plymouth-calculate-plugin требует именно 0.9.4, если только пакет не прописан у вас в /var/lib/portage/world. На данный момент еще нет патча для версии 0.9.5.

Для plymouth или plymouth-calculate-plugin?

У меня не прописаны, но обновления sys-boot/plymouth не происходит.
Использую только cl-update --verbose, а emerge только для установки или удаления пакетов.

для sys-boot/plymouth 0.9.5

В файле /var/lib/portage/world, этого пакета sys-boot/plymouth-calculate-plugin нет,
Стараюсь делать так, чтобы в /var/lib/portage/world не записывалось ничего лишнего.

Не знаю как у вас, господа, но у меня sys-boot/plymouth-0.9.5-r1 не собирается.build.log (70.4 KB)
Может быть какие лишние флаги затесались.

[1;32m*e[0m Применение патчей Calculate утилитами для plymouth ...
[1;31m*e[0m Исправление не удалось
[1;33m*e[0m Не удалось применить патч /var/db/repos/calculate/profiles/templates/3.6/6_ac_install_patch/sys-boot/plymouth/plymouth-init_fb.patch
[1;32m*e[0m Применение патча plymouth-shutdown.patch
[1;33m*e[0m Утилиты Calculate изменили файлы:
[1;32m*e[0m      src/main.c

Опять 25
Ошибка при обновлении
sys-boot/plymouth:0

(sys-boot/plymouth-0.9.5-r1:0/0::gentoo, ebuild scheduled for merge) USE=“gtk libkms pango (split-usr) udev -debug -static-libs” ABI_X86="(64)" conflicts with
~sys-boot/plymouth-0.9.4[gtk,libkms,pango,split-usr] required by (sys-boot/plymouth-calculate-plugin-0.9.4-r3:0/0::calculate, installed) USE=“gtk libkms pango (split-usr) -debug -gdm -static-libs” ABI_X86="(64)"

Как решить?
Замаскировать sys-boot/plymouth-0.9.5-r1 или снести sys-boot/plymouth-calculate-plugin-0.9.4-r3

Замаскировать.

интересно почему вылезло sys-boot/plymouth-0.9.5-r1

© 2007-2020 Calculate Ltd.
Mastodon Mastodon