CalculatešŸ§Forum

Playonlinux doesnt start after update

#1

Hi,
After last update I have exactly same problem as in this Gentoo forum post:

https://forums.gentoo.org/viewtopic-p-8217732.html?sid=04ee8779d5b7a3f893fa68e89b5b454d

It is suggested to recompile x11-libs/wxGTK

How would I do that?

Thanks.

#2

Strangely 3 minutes after I posted this, there was an update to wxGTK package, but unfortunately I still have the problem. This is what I get in terminal

polaca57@calculate ~ $ playonlinux
Looking for python... 3.6.5 - skipped
Looking for python2.7... 2.7.14 - wxversion(s): 3.0-gtk2
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8).
/usr/share/playonlinux/bash/find_python: line 58:  6154 Aborted                 "$POL_PYTHON" "$POLDIR/python/check_python.py"
failed tests
Looking for python2.6... which: no python2.6 in (/usr/x86_64-pc-linux-gnu/gcc-bin/7.3.0:/usr/lib/llvm/6/bin:/usr/lib/llvm/5/bin:/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/games/bin)

Looking for python2... 2.7.14 - wxversion(s): 3.0-gtk2
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8).
/usr/share/playonlinux/bash/find_python: line 58:  6161 Aborted                 "$POL_PYTHON" "$POLDIR/python/check_python.py"
failed tests
Please install python before trying to run this program
#3

So it looks like I solved it.
I am not command line fan and I use Porthole to install packages. So thanks to Porthole I discovered, by using Advance Emerge, that there was an unsupported use flag enabled for x11-libs/wxGTK 3.0.4-r300. I unchecked abi_x86_64 flag and then emerged x11-libs/wxGTK 3.0.4-r300 package.

All seems fine now, Playonlinux/Photoshop CS6 starts as before.

Did I do the right thing?

#4

check that you have the latest version of PlayOnLinux (4.1.6)

Paste those lines in your Terminal
Code:
wget -q ā€œhttp://deb.playonlinux.com/public.gpgā€ O | sudo apt-key add -
sudo wget http://deb.playonlinux.com/playonlinux_precise.list -O /etc/apt/sources.list.d/playonlinux.list
sudo apt-get update
sudo apt-get upgrade
I read about some python related issues, so if the above is not working then try it with the latest development version
Code:
git clone https://github.com/PlayOnLinux/POL-POM-4
To use it
Code:
cd ~/POL-POM-4/
playonlinux

#5

Please check that you have the latest version of PlayOnLinux (4.1.6)

Paste those lines in your Terminal

Code:

wget -q ā€œhttp://deb.playonlinux.com/public.gpgā€ -O- | sudo apt-key add - sudo wget http://deb.playonlinux.com/playonlinux_precise.list -O /etc/apt/sources.list.d/playonlinux.list sudo apt-get update sudo apt-get upgrade

I read about some python related issues, so if the above is not working then try it with the latest development version

Code:

git clone https://github.com/PlayOnLinux/POL-POM-4

To use it

Code:

cd ~/POL-POM-4/ playonlinux

Alternatively use Wine.

Mastodon Mastodon