[решено] Openshot не устанавливается в 13.11 и 20131127 из-за конфликта пакетов

Openshot не устанавливается в стандартной поставке 13.11 и 20131127, а также обновлённой по 04.12.2013 из-за конфликта пакетов.
Кому-то удалось установить openshot? Как?
emerge --autounmask-write openshot && dispatch-conf не помогает.

Вот прямой вывод emerge -uDp openshot:
http://pastebin.calculate-linux.ru/ru/show/6012
Или вот копия терминала из emerge -uDa openshot:
http://pastebin.calculate-linux.ru/ru/show/6015

Спасибо.

Да, это одна из мелких досадных неприятнойстей связанных с PIL в gentoo
Старые версии назывались dev-python/imaging, а последующие - dev-python/pillow
Калькоутилиты тянут по зависимостям virtual/python-imaging, который в свою очередь тянет dev-python/pillow (последняя стабильная версия) или dev-python/imaging (до этого)
Мне также был необходим пакет dev-python/imaging для одной утилиты, и я решил это просто:

echo '>virtual/python-imaging-1' >> /etc/portage/package.mask/custom
emerge -Ca dev-python/pillow
emerge -avt1 virtual/python-imaging

Выполните то же самое, и после этого, думаю, у вас нормально соберется openshot

PS
При выполнении установки пакетов советую использовать ключи
--ask [ y | n ] (-a short option)
и
--tree (-t)
Подробности о них найдете в
man emerge

PPS

По какой-то причине ebuild openshot-а в портежах описан как KEYWORDS="~amd64"
Но у него есть преимущество - в зависимостях у него прописан virtual/python-imaging вместо dev-python/imaging как в оверлее.

Попробуйте выполнить
echo 'media-video/openshot **' >>/etc/portage/package.keywords/custom
и после этого собрать openshot.
Должно нормально собраться и с dev-python/pillow

Спасибо за советы! Попробую сделать по второму варианту (PPS).
Надеюсь, оно заработает на x86 не смотря на KEYWORDS="~amd64"…

Надеюсь, оно заработает на x86 не смотря на KEYWORDS="~amd64"…
Должно
И, кстати, если заработает - отпишитесь тут, надо будет в генту-багз написать чтоб ebuild подправили

Первый шаг сделал как у вас в PPS написано. Получил следующее:
http://pastebin.calculate-linux.ru/ru/show/6020
Затем сделал --autounmask-write и dispatch-conf
Теперь вроде работает (компилируется). Дело в настоящий момент в процессе, так что как будут окончательные результаты, отпишусь.

UPD: Всё сработало! Openshot установлен и работает. Спасибо большое.
Итак, что сделал:

  1. echo ‘media-video/openshot ****’ >>/etc/portage/package.keywords/custom
  2. emerge --autounmask-write openshot
  3. dispatch-conf (ответ u два раза)
  4. emerge -uDa openshot