Calculate Forum

Настройка nginx + php-fpm

Пробую настроить по местной вики. Удивительно, но не работает… В /etc/nginx/nginx.conf по умолчанию root /var/www и т.д., в гайде же root /var/calculate/www. Если это свести к одинаковому значению в обоих файлах, то curl http://localhost отрабатывает правильно. Если далее строго по гайду подключать php-fpm, то при запросе http://localhost/info.php про скачается этот файл. В примерах для example.org.conf показатель root то /var/calculate/www/example.org/htdocs; то /var/calculate/www/localhost/htdocs; . Может быть кто-то из людей в теме меня в чем-то просветит или сделает инструкцию более подробной?

Попытался разобраться с проблемой “самостоятельно”. Погуглив довольно таки много получил работающую связку nginx+php-fpm+mariadb+wordpress на пк по адресу localhost. Файл /etc/nginx/sites-enabled/local.conf был взят из вики и изменять его не пришлось. Основным полем изменений стал /etc/nginx/nginx.conf. В него были внесены следующие изменения:

  1. Строка index index.html; изменена на index index.php index.html;
  2. Исправлен default_type application/octet-stream; на default_type text/html; Если этого не сделать, то php файлы будут скачиваться браузером. Для перестраховки в /etc/nginx/mime.types добавил text/php php;
  3. Во избежание проблем с импортом файла данных wordpress пришлось добавить client_max_body_size 16M; Размер зависит от вашего случая.
  4. Для реализации ЧПУ (permalinks) в wordpress в блоке server добавил два location
location / {
                try_files $uri $uri/ /index.php?$args;
        }
location ~ \.php$ {
            try_files $uri =404;
        include /etc/nginx/fastcgi.conf;
        fastcgi_pass unix:/run/php-fpm.socket;
        }

P.S.Описан личный опыт и на универсальность я не претендую…

© 2007-2020 Calculate Ltd.
Mastodon Mastodon