Calculate Forum

Nettle похоже опять приводит к проблемам

На паре машин после обновления поставилась dev-libs/nettle-3.6-r2
После этого claws-mail, rdesktop и наверное еще что-то стали неработоспособны.
Похожая ситуация была ранее с dev-libs/nettle-3.5.1-r1 и ее маскировали системно.
На одной из машин перед обновой замаскировал и там все в норме после обновы.
Откат на nettle-3.4.1на проблемных машинах по простому не получается, в зависимости лезет много чего.
И как теперь восстановить работоспособность rdesktop, claws-mail и иже с ними непонятно.
PS Маскировка типа >dev-libs/nettle-3.4.1 не срабатывает при обновлении через ISO из nightly/20200710/ и там все сразу “сломано”.

У меня - vpn, пришлось откатываться и пересобирать gnutls и всё остальное по зависимостям

PS об этом уже в Проблема с новым gnutls есть

выровнял ситуацию, правда по другому.

Замаскировал >dev-libs/nettle-3.4.1
Снес проблемные пакеты gnutls, claws-mail, rdesktop
Установил dev-libs/nettle-3.4.1
По очереди установил удаленные пакеты с опцией
emerge --autounmask-keep-masks
После этого прошло без ошибок cl-update и проблемные пакеты заработали.
Может это и “кривой” путь, но сработало.

С https еще проблемы.

Проблема решена. Обсуждение в соседней ветке Проблема с новым gnutls

© 2007-2020 Calculate Ltd.
Mastodon Mastodon