Настройка_mysql&apache&php

1. Установка первой части (mysql) прошла без вопросов. Непосредственно пакет установлен со следующими флагами:
dev-db/mysql-5.1.70 USE=“community embedded perl ssl -big-tables -cluster -debug -extraengine -latin1 -max-idx-128 -minimal -pbxt -profiling (-selinux) -static {-test} -xtradb”

2. Попытка установить пароль, выдает следующее:

 # mysql -u root -h localhost -p
Enter password: 
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

Уже видимо занят или не может соединиться с сокетом, только вот кем или почему?

3. Ответ видимо можно найти здесь:

 # ps -aux | grep mysql
root     30272  0.0  0.0  23008   916 pts/1    S+   18:56   0:00 grep --colour=auto mysql

4. Соответственно и при попытке запустить сервис машина выдает следующее:

 # /etc/init.d/mysql start
mysql             | * Starting mysql ...
mysql             | * start-stop-daemon: caught an interrupt
mysql             | * start-stop-daemon: /usr/sbin/mysqld died                                                                                                                       [ !! ]
mysql             | * ERROR: mysql failed to start

И теперь вообщем-то “банальный” вопрос - что с этим всем делать или как запустить сервис?

Попытки погуглить равно как и проискать ответ на вопрос на здешнем форуме, вразумительных ответов не дали!
Вариант http://www.gentoo.org/doc/ru/mysql-howto.xml кроме по умолчанию запущенного сервиса ответов так же не дает!

В /var/log/messages что-нибудь есть по поводу того почему именно не стартует демон?

#wgetpaste -r ‘/var/log/mysql/mysqld.err’

http://pastebin.calculate-linux.ru/ru/show/5748

[ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.

mysql_upgrade не помогает?

# mysql_upgrade
Looking for ‘mysql’ as: mysql
Looking for ‘mysqlcheck’ as: mysqlcheck
Running ‘mysqlcheck’ with connection arguments: ‘–port=3306’ ‘–socket=/var/run/mysqld/mysqld.sock’
mysqlcheck: Got error: 2002: Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2) when trying to connect
FATAL ERROR: Upgrade failed

Похоже, что не помогает :frowning: ?

Это “нулевая” установка MySQL ?
Не апгрейд?
Если “нулевая” помогает скрипт:

/usr/bin/mysql_install_db

который можно запустить без параметров.

Спасибо, получилось запустить…

 # /usr/bin/mysql_install_db
Installing MySQL system tables...
OK
Filling help tables...
OK

To start mysqld at boot time you have to copy
support-files/mysql.server to the right place for your system

PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !
To do so, start the server, then issue the following commands:

/usr/bin/mysqladmin -u root password 'new-password'
/usr/bin/mysqladmin -u root -h calculate password 'new-password'

Alternatively you can run:
/usr/bin/mysql_secure_installation

which will also give you the option of removing the test
databases and anonymous user created by default.  This is
strongly recommended for production servers.

See the manual for more instructions.

You can start the MySQL daemon with:
cd /usr ; /usr/bin/mysqld_safe &

You can test the MySQL daemon with mysql-test-run.pl
cd /usr/mysql-test ; perl mysql-test-run.pl

Please report any problems with the /usr/scripts/mysqlbug script!

… теперь посмотрим, что Apache скажет…?

Андрей Сеник wrote:

Это “нулевая” установка MySQL ?
Не апгрейд?
Если “нулевая” помогает скрипт:
[…]
который можно запустить без параметров.

А если уже не первый запуск мускула, и вот такие ошибки:

http://pastebin.com/v0qvxtzS

Что тогда делать, подскажите пожалуйста?

почти по русски вам там написали :slight_smile:

Please enter a valid host, username and password

Станислав Сухоруков wrote:

А если уже не первый запуск мускула, и вот такие ошибки:

http://pastebin.com/v0qvxtzS

Что тогда делать, подскажите пожалуйста?

У вас есть какая та БД, которую вы установили.
И в каком-то конфиге sugarcrm (далее по тексту - фигня) есть упоминание о пользователе и его пароле, с которым эта фигня будет лезть в БД.
Обычно, все это описано где-нибудь в ридми к фигне.
А вкратце, нужно или создать пользователя с паролем и дать доступ к БД (смотреть GRANT USER…) или отредактировать существующий. Ну и само собой в фиговом конфиге указать хост, пользователя и пароль.

Установка LAMP прошла успешно, в дополнение установил phpmyadmin
вроде все работает но при входе в http://localhost/phpmyadmin
на главной странице есть строчка
Расширение mysqli не найдено. Пожалуйста, проверьте ваши настройки PHP.

Как установить это расширение ?

# Собрать php с <>
# Включить в php.ini

extension=php_mysqli.dll