mounting dvd and usb on 10.9 gnome SOLVED

hi, how do I mount my dvd drive and usb’s in 10.9
I have changed permissions in cdrom to user and the dvd is recognized by name in my file system but will not mount or play.
Enjoying Calculate

Add user to the following groups if they are not in the output of execute command ‘id’

gpasswd -a user_name plugdev
gpasswd -a user_name cdrom
gpasswd -a user_name audio
gpasswd -a user_name video

I already did this and it makes no difference to mounting cdrom.

root user can mount the drive?


mount -t iso9660 -o ro /dev/cdrom /media/cdrom
mount: mount point /media/cdrom does not exist

I have in my fstab the line:
/dev/cdrom /mnt/cdrom auto noauto,users,ro 0 0

Is this correct?
Should the line be commented out?

Show output when you run (the disc must be inserted).

mount /dev/cdrom /mnt/cdrom

#mount /dev/cdrom /mnt/cdrom (disc is inserted)

mount: block device /dev/sr0 is write-protected, mounting read-only
mount: you must specify the filesystem type

I hope this helps

You are using an audio CD?
Try to run with another CD or DVD disc.

Yes I was using an audio cd but now I tried a commercial dvd video (not home made)
I put the dvd in and ran the command as root “mount /dev/cdrom /mnt/cdrom” and got the message
“mount: block device /dev/sr0 is write-protected, mounting read-only.”

The dvd is not mounted automatically but when I opened VLC and “open file” it lists “mnt cdrom video_ts” and all the individual .vob files underneath.
VLC will play the .vob files but the video and sound is all garbled.

Movie player also finds the video but will not open it.


Use media-video/smplayer
DVD disk must be mounted without a team when inserting the drive.

I emerged smplayer and libdvdread
dvd is not auto mounted but smplayer can find the video file and when I hit play
it fails and the log file is as below:-

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a long time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x0000012c
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x0000170c
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00001739

You have an encrypted dvd disk

Use app-cdr/k9copy or analog.

Thanks Alexey,
I emerged k9copy and now I can play DVD’s with VLC or smplayer.
They don’t auto mount to the desktop but it’s easy to find them within the players.
Thanks for all the information