Locale Settings in Calculate Utilities Not Retained

Hi All,
Just over a week ago I posted a message about a problem that I was having setting the en_AU locale. As I suspected, the cause of that problem was that my locale was not present in Calculate Utilities. It has since been added (Thanks Again Alexander), but I am still having problems getting cldx to retain my locale settings. I’ve decided to start a new thread with this message, because the cause now appears to be different. I am now able to select the en_AU locale in Calculate utilities, and I have made sure that the “en_AU.UTF-8 UTF-8 " locale is present in /etc/locale.gen and is the only locale present in /etc/env.d/02locale. I can temporarily assign the en_AU locale for the current user by running the command " . /etc/profile”. Also, the English Australian locale appears correctly in Calculate Console. All of this would seem to indicate that the locale is set correctly in Calculate Utilities, but this is somehow not being transferred to the system settings. I am also still running cldm on another computer and I don’t have this problem so whatever the cause is, it seems to be specific to cldx. I’ve attached a text file containing the command line output from a couple of login sessions, that I think may help to define the issue. I’ll feel awfully silly if I’ve overlooked something simple.

command_line_text (6.69 KB)

locale is a pain in the …

I had these problems too

forenow it is good

calculate ferdi # locale
calculate ferdi # locale -a
calculate ferdi # eselect locale list
Available targets for the LANG variable:
[1] C
[2] nl_BE.utf8 *
[ ] (free form)
calculate ferdi #

hope this helps

:wink: ferdi

What kind of locale do you want use? en_AU or other?

no no,

my locale are OK now, for flemish belgium,
only it’s strange “locale -a” shows “nl_BE.utf8” and not like my “make.conf/custom” says

LINGUAS=“nl en”
L10N=“nl en”

and “eselect locale list”

“en” is not there.

but it’s ok so,

:wink: see this as solved for now.

Thank you Mikhail and Ferdi for your replies. I eventually gave up on this problem with cldx and switched to cld (kde desktop). CLD is working fine with the correct locale for me “en_AU”. Just as an aside - I have found that the CLD implementation of KDE Plasma 5 is very good. It’s fast and doesn’t suffer from the instability that I have experienced with that dte in some other distros that I have tried.