Calculate Forum

Lightdm fails to start on new Xfce4 installation

Thanks for creating such a fantastic Distro.
I had been using Gentoo for a long time and just yesterday I installed the Xfce4 version of Calculate.
I was really impressed that in the rare occasion one might need an extra USE flag etc then emerge will build the package from source rather than use the binary version of it.
I feel extremely excited about Calculate and see no reason why one would prefer Gentoo other than maybe customize the cflags to reflect their processor.
HOWEVER 3 problems:

  1. The default kernel vmlinuz-5.4.6-calculate does not have full iptables functionality needed for VM bridging and docker
    2)Lightdm does not start.I have to login in text mode and then use “startx”.
    3)Why all this grub gfx settings???Who CARES? Although I specifically disabled gfx mode @install they appeared in /etc/default/grub.
    For me the most important problem that is fast dissipating my initial enthusiasm about Calculate is the Lightdm problem.
    Any feedback would be greatly appreciated.
    Xdm enabled
    dbus enabled
    xdm set to start lightdm in /etc/conf.d/xdm
    BUT IT WILL NOT START
    UPDATE: after entering a cron entry to restart xdm @reboot it finally WORKS!!!
    BUT:Although I have set the greeter to be my wallpaper ,upon login it shows my wallpaper,then briefly switches to calculate default background twice and only then it settles permanently on my wallpaper.
    WHY might that be?

H! Thanks for your feedback.

  1. Write what options you are missing in the kernel and we will add them. Try using cl-kernel to build a kernel with your own configuration.
  2. Which distribution do you use? Xorg does not start only in Calculate Linux Scratch. It is for the guru.
  3. The configuration files in the system are configured by the templates of Calculate utils. To keep them from changing, create your own template. The easiest way to create a copy of the file with the clt extension (cp /etc/default/grub /etc/default/grub.clt).

Lautre
Thanks for your kind reply.
I am using CLDX…
I was missing apparently netfilter config from the kernel(pertaining to nat).
At least so docker complained @installation.
So I instead I used my own precompiled 4.19.88 kernel.
It worked as a charm.
Thanks for the cl-kernel tip.
I was unaware.
I also resolved the problem with lightdm by commenting out the

#session-setup-script=/usr/share/calculate/xdm/xdm --login
#session-cleanup-script=/usr/share/calculate/xdm/xdm --logout

in
/etc/lightdm/lightdm.conf.
I love Calculate :slight_smile:
As for Grub i replaced the entire /etc/grub.d with one from Gentoo.
A Note for the developers:
When I tried to chainload arch from calculate grub menu,grub complained about no video “booting in blind mode” and then I had to hard reboot.
Also something is going on about languages because arch also complained that:“you are login in with a different language do you want to rename your folders”
So something nasty is going on about maybe gfx settings in /etc/grub.d
So I just replaced it with gentoo’s and removed ALL gfx settings from /etc/default/grub and used “console”.Maybe you would like to have a look at it :slight_smile:
All is vanilla smooth now.
Thanks to the developers and the community for bringing out such a fantastic Distro
Happy New Year
:slight_smile:

Mastodon Mastodon